aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-01 21:12:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 15:43:10 +0100
commit547a66446b0116c8381cf32224ee83fcf1362d55 (patch)
treed65b3102c549ceef5c6764f4222f571f72a37b38
parentb6085ae28d1c9e3e45a99ab608861a8cf8678dbf (diff)
downloadguix-547a66446b0116c8381cf32224ee83fcf1362d55.tar.gz
guix-547a66446b0116c8381cf32224ee83fcf1362d55.zip
gnu: Add go-github-com-pion-sdp-v3.
* gnu/packages/golang-web.scm (go-github-com-pion-sdp-v3): New variable. Change-Id: I74fe6598784498ed1bacca6acfce4cfcd741022d
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 4de417cd30..5ab46d31a3 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3758,6 +3758,33 @@ Protocol,SCTP} as specified in
@uref{https://rfc-editor.org/rfc/rfc9260.html,RFC 9260}.")
(license license:expat)))
+(define-public go-github-com-pion-sdp-v3
+ (package
+ (name "go-github-com-pion-sdp-v3")
+ (version "3.0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/sdp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08d3glli1n45ayc26qwaxm7k5knrf99x5nwkllmmhf29g8kwc89n"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pion/sdp/v3"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-pion-randutil))
+ (home-page "https://github.com/pion/sdp")
+ (synopsis "Implementation of the SDP protocol in Golang")
+ (description
+ "Package sdp implements @acronym{Session Description Protocol,SDP}.")
+ (license license:expat)))
+
(define-public go-github-com-pion-stun
(package
(name "go-github-com-pion-stun")