aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:39 +0200
commit5445b744c84bacffe7bb975300fa6a5f46e945f8 (patch)
tree3573a07656feefd0605e6627f8fd2b5f1ddcef7e
parent75cecfaab06b4be9cedaa4882d55fa3f59100a9c (diff)
downloadguix-5445b744c84bacffe7bb975300fa6a5f46e945f8.tar.gz
guix-5445b744c84bacffe7bb975300fa6a5f46e945f8.zip
gnu: Add texlive-tabstackengine.
* gnu/packages/tex.scm (texlive-tabstackengine): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1600614f2f..1388e18ed7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97212,6 +97212,30 @@ areas where the function is not defined, or placing special values. Several
features of the variation tables can be customized.")
(license license:lppl1.3+)))
+(define-public texlive-tabstackengine
+ (package
+ (name "texlive-tabstackengine")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tabstackengine/"
+ "tex/latex/tabstackengine/")
+ (base32
+ "1qj9w9rjsakrijy953ab2sa5k92npvvm4zz1y2z4k4a78g981q0n")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tabstackengine")
+ (synopsis "\"Tabbing\" front-end to stackengine")
+ (description
+ "The package provides a front end to the @code{stackengine} package,
+to allow tabbed stacking. In most cases, an existing @code{stackengine}
+command may be prepended with the word @samp{tabbed}, @samp{align} or
+@samp{tabular} to create a new tabbed version of a stacking macro. In
+addition, hooks in the package's parser that tabbed strings of data may be
+parsed, extracted, and reconstituted (not requiring use of any stacking
+constructions).")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar