aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-06 17:05:27 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:03 +0000
commit53d60540fa39f3aff7679a48393d797c5ea92fff (patch)
treed984202a712b1d6916ece425093188e99500b4d1
parent803a46bb9003a7ca23a8b2c2f71ec01a4314d367 (diff)
downloadguix-53d60540fa39f3aff7679a48393d797c5ea92fff.tar.gz
guix-53d60540fa39f3aff7679a48393d797c5ea92fff.zip
gnu: behave: Update to 1.2.7.dev5.
* gnu/packages/check.scm (behave): Update to 1.2.7.dev5. [native-inputs]: Add python-assertpy, python-pytest-html, python-setuptools, and python-wheel. Change-Id: I238fe5aea580ae8e884d085d4dccfe6f4030b030
-rw-r--r--gnu/packages/check.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3beda41bbd..654306c41c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3369,7 +3369,7 @@ backported from Python 2.7 for Python 2.4+.")
(name "behave")
;; The 1.2.6 release from 2018 has several problems with newer Python
;; versions, so we package a recent snapshot.
- (version "1.2.7.dev2")
+ (version "1.2.7.dev5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3378,11 +3378,18 @@ backported from Python 2.7 for Python 2.4+.")
(file-name (git-file-name name version))
(sha256
(base32
- "0sv94wagi214h0l91zn8m04f78x5wn83vqxib81hnl1qahvx9hq7"))))
+ "14162pclfvy4wy2az4v9gkgb3v0b338zxrb2ikqcqifckrmk8nhv"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-mock python-nose python-pathpy python-pyhamcrest
- python-pytest))
+ (list python-mock
+ python-nose
+ python-assertpy
+ python-pathpy
+ python-pyhamcrest
+ python-pytest
+ python-pytest-html
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-colorama
python-cucumber-tag-expressions