aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-10 21:25:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:19 +0000
commit5368eff86608ac0e970053e73bab1cdab35d6495 (patch)
tree4d5972fd7ab30b0bdb1f67a1db4ba7c5b4771d1b
parent465b17b74afe0eeb9c266b220f7104cab2dc3257 (diff)
downloadguix-5368eff86608ac0e970053e73bab1cdab35d6495.tar.gz
guix-5368eff86608ac0e970053e73bab1cdab35d6495.zip
gnu: Add python-halotools.
* gnu/packages/astronomy.scm (python-halotools): New variable. Change-Id: Ia7907d0988738fe37835d2f02310ae74bba37e0a
-rw-r--r--gnu/packages/astronomy.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ecf9ab3468..b3b94b0471 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2114,6 +2114,51 @@ across many files.")
(description "Multidimensional data visualization across files.")
(license license:bsd-3)))
+(define-public python-halotools
+ (package
+ (name "python-halotools")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "halotools" version))
+ (sha256
+ (base32 "1fn74ljb4yv3nprgzaf9awiyjdvkmzf1a1n2kvajbax835qcs3bz"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Tests are shaky in parallel.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (native-inputs
+ (list python-cython-3
+ python-extension-helpers
+ python-pytest
+ python-pytest-astropy
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-astropy
+ python-beautifulsoup4
+ python-h5py
+ python-numpy
+ python-requests
+ python-scipy))
+ (home-page "http://halotools.rtfd.org/")
+ (synopsis "N-body simulations and constrain models of cosmology evolution")
+ (description
+ "Halotools is a specialized python package for building and testing
+models of the galaxy-halo connection, and analyzing catalogs of dark matter
+halos. The core feature of Halotools is a modular platform for creating mock
+universes of galaxies starting from a catalog of dark matter halos obtained
+from a cosmological simulation.")
+ (license license:bsd-3)))
+
(define-public python-healpy
(package
(name "python-healpy")