aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 11:50:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:28:46 +0200
commit51acbd1c32c46307e00e32e19773f581d6cb902a (patch)
treeb3ddd7c9043e1f9dcf6f48dcf8dd04c761c4ebdf
parentbe76eabd9d99496e6ac441df786ea5453217c17e (diff)
downloadguix-51acbd1c32c46307e00e32e19773f581d6cb902a.tar.gz
guix-51acbd1c32c46307e00e32e19773f581d6cb902a.zip
gnu: Add texlive-braille.
* gnu/packages/tex.scm (texlive-braille): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2779292130..b92c83e48c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6433,6 +6433,27 @@ those long IUPAC compound names, and some chemical idioms. It also supports
the labelling of compounds and reference to labelled compounds.")
(license license:lppl)))
+(define-public texlive-braille
+ (package
+ (name "texlive-braille")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/braille/" "tex/latex/braille/")
+ (base32
+ "021nxjz23gn8zjrrzxggjaqq3gv894c512x15kffywm8h5k0bzy5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/braille")
+ (synopsis "Support for Braille")
+ (description
+ "This package allows the user to produce Braille documents on paper for
+the blind without knowing Braille. Python scripts @file{grade1.py} and
+@file{grade2.py} convert ordinary text to grade 1 and 2 Braille tags; then,
+the LaTeX package takes the tags and prints out corresponding Braille
+symbols.")
+ (license license:lppl1.3+)))
+
(define-public texlive-breakcites
(package
(name "texlive-breakcites")