aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-06 16:45:44 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:03 +0000
commit50d3f1f78203c95ee1aa65e89c4b511b881dd80b (patch)
tree140598f97dc784f28dd9a446ff2e53cadb5e49c6
parent174c1bf0e3862663d334dd2e74b6fc1a8a2ceae0 (diff)
downloadguix-50d3f1f78203c95ee1aa65e89c4b511b881dd80b.tar.gz
guix-50d3f1f78203c95ee1aa65e89c4b511b881dd80b.zip
gnu: python-cucumber-tag-expressions: Update to 6.1.1.
* gnu/packages/python-check.scm (python-cucumber-tag-expressions): Update to 6.1.1. [source]: Swap to git checkout containing tests. [arguments]<phases>: Add chdir-phython phase. [home-page]: Fix URL. [native-inputs]: Remove python-invoke; add python-pytest-html, python-pyyaml, python-setuptools, python-setuptools-scm, and python-wheel. Change-Id: Ia028ae6fa7987194ee50f532209626733b50275a
-rw-r--r--gnu/packages/python-check.scm31
1 files changed, 25 insertions, 6 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 7fc4fe1a83..f38dded9df 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -302,17 +302,36 @@ are useful when writing automated tests in Python.")
(define-public python-cucumber-tag-expressions
(package
(name "python-cucumber-tag-expressions")
- (version "4.1.0")
+ (version "6.1.1")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "cucumber-tag-expressions" version))
+ (method git-fetch) ;no tests in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/cucumber/tag-expressions")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0q7rn4l4ppjd1zsglr37ccc5xccg4iigaw827282zfzfsvzda573"))))
+ (base32
+ "1hanh7hzxmx0f6fp2ykabsg32snmp8y9pd7s5xix15r1gnn7lvp9"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Project's repository contains go, java, javascript, perl, python
+ ;; and ruby implementations.
+ (add-after 'unpack 'chdir-python
+ (lambda _
+ (chdir "python"))))))
(native-inputs
- (list python-invoke python-pathpy python-pytest))
- (home-page "https://github.com/cucumber/tag-expressions-python")
+ (list python-pathpy
+ python-pytest
+ python-pytest-html
+ python-pyyaml
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (home-page "https://github.com/cucumber/tag-expressions")
(synopsis "Tag-expression parser for cucumber/behave")
(description
"This package provides a tag-expression parser for Cucumber and