aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-22 21:27:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:44 +0200
commit4ee6a84585c70ec968ef37eeefbb144f2c4f68ed (patch)
treef8cd194d5bf15485e5109abfe91c940013114475
parentcabafd38b4914ff1d24eb5f25aa69c9faa8a52df (diff)
downloadguix-4ee6a84585c70ec968ef37eeefbb144f2c4f68ed.tar.gz
guix-4ee6a84585c70ec968ef37eeefbb144f2c4f68ed.zip
gnu: Add rust-sequoia-cert-store-0.6.
* gnu/packages/sequoia.scm (rust-sequoia-cert-store-0.6): New variable. (rust-sequoia-cert-store-0.5): Remove variable. Change-Id: Iea2fd64f2cc16ff31026b09add793d9503e0830b
-rw-r--r--gnu/packages/sequoia.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index a9b872830b..1729d914cd 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -101,23 +101,24 @@ and decoding of Autocrypt headers and setup messages. Note: Autocrypt is more
than just headers; it requires tight integration with the MUA.")
(license license:lgpl2.0+)))
-(define-public rust-sequoia-cert-store-0.5
+(define-public rust-sequoia-cert-store-0.6
(package
(name "rust-sequoia-cert-store")
- (version "0.5.0")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "sequoia-cert-store" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1rjakcnhwdvwrm0952rpi9ky8cxvv5bnmylval49s3a087jqcm76"))))
+ (base32 "14f3zhkh0hrjmkv6ksvyr29z6mfq1hadqzqsvhp3xwlf9y66bhjg"))))
(build-system cargo-build-system)
(arguments
`(#:features '("sequoia-openpgp/crypto-nettle")
#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
("rust-crossbeam" ,rust-crossbeam-0.8)
("rust-dirs" ,rust-dirs-5)
+ ("rust-gethostname" ,rust-gethostname-0.4)
("rust-num-cpus" ,rust-num-cpus-1)
("rust-openpgp-cert-d" ,rust-openpgp-cert-d-0.3)
("rust-rayon" ,rust-rayon-1)
@@ -126,8 +127,11 @@ than just headers; it requires tight integration with the MUA.")
("rust-sequoia-openpgp" ,rust-sequoia-openpgp-1)
("rust-smallvec" ,rust-smallvec-1)
("rust-thiserror" ,rust-thiserror-1)
- ("rust-tokio" ,rust-tokio-1))
- #:cargo-development-inputs (("rust-sequoia-openpgp" ,rust-sequoia-openpgp-1)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-url" ,rust-url-2))
+ #:cargo-development-inputs (("rust-rand" ,rust-rand-0.8)
+ ("rust-rusty-fork" ,rust-rusty-fork-0.3)
+ ("rust-sequoia-openpgp" ,rust-sequoia-openpgp-1)
("rust-tempfile" ,rust-tempfile-3))))
(native-inputs
(list clang pkg-config))