aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-04-06 21:37:24 +0800
committerLudovic Courtès <ludo@gnu.org>2016-04-16 11:46:50 +0200
commit4ec331b2b4c9dfda3467b92093c37805d4072b9a (patch)
treed97eb174a3b1b7e934ddeb9b547583616332c748
parentc14a524ce550ab70af566264663d16e6689d4626 (diff)
downloadguix-4ec331b2b4c9dfda3467b92093c37805d4072b9a.tar.gz
guix-4ec331b2b4c9dfda3467b92093c37805d4072b9a.zip
gnu: gnumeric: Fix build.
* gnu/packages/gnome.scm (gnumeric)[native-inputs]: Add bison. [inputs]: Replace python2-pygobject with python2-pygobject.
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 23feed112f..8e4597b2bd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1584,10 +1584,11 @@ Hints specification (EWMH).")
("libxml2" ,libxml2)
("libxslt" ,libxslt)
("python" ,python-2)
- ("python2-pygobject" ,python2-pygobject-2)
+ ("python2-pygobject" ,python2-pygobject)
("zlib" ,zlib)))
(native-inputs
- `(("intltool" ,intltool)
+ `(("bison" ,bison)
+ ("intltool" ,intltool)
("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page "http://www.gnumeric.org")
ackages/prolog.scm, gnu/packages/protobuf.scm, gnu/packages/pulseaudio.scm, gnu/packages/python-crypto.scm, gnu/packages/python-web.scm, gnu/packages/python-xyz.scm, gnu/packages/qt.scm, gnu/packages/radio.scm, gnu/packages/rails.scm, gnu/packages/rdf.scm, gnu/packages/rednotebook.scm, gnu/packages/rpc.scm, gnu/packages/rsync.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/screen.scm, gnu/packages/security-token.scm, gnu/packages/selinux.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/shellutils.scm, gnu/packages/simh.scm, gnu/packages/sml.scm, gnu/packages/ssh.scm, gnu/packages/statistics.scm, gnu/packages/stenography.scm, gnu/packages/sync.scm, gnu/packages/syncthing.scm, gnu/packages/synergy.scm, gnu/packages/telephony.scm, gnu/packages/terminals.scm, gnu/packages/tex.scm, gnu/packages/texinfo.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tmux.scm, gnu/packages/tor.scm, gnu/packages/toys.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/virtualization.scm, gnu/packages/vlang.scm, gnu/packages/vnc.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wireservice.scm, gnu/packages/wm.scm, gnu/packages/wxwidgets.scm, gnu/packages/xdisorg.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, tests/lint.scm: Remove trailing ".git" from 'git-reference' URL. 2020-07-05gnu: rubber: Update to 1.5.1.Arun Isaac * gnu/packages/tex.scm (rubber): Update to 1.5.1. [build-system]: Switch to python-build-system. [inputs]: Remove python-2 and which. [arguments]: Delete the build phase. Replace the install phase with a custom phase. 2020-06-11gnu: lyx: Use qt-build-system.Efraim Flashner * gnu/packages/tex.scm (lyx)[build-system]: Switch to qt-build-system. [arguments]: Remove imported modules. Remove custom 'wrap-qt phase. 2020-06-11gnu: lyx: Don't install to custom directory.Efraim Flashner * gnu/packages/tex.scm (lyx)[arguments]: Adjust configure-flags to not add the version to the binary's suffix. Remove custom 'patch-desktop-file, 'setenv-check and 'install-symlink phases. 2020-06-11gnu: lyx: Update to 2.3.5.1.Efraim Flashner * gnu/packages/tex.scm (lyx): Update to 2.3.5.1. [arguments]: Remove 'fix-compilation-with-boost-1.69 phase. In 'patch-python phase patch more files, substitute with python3. Split 'setenv-check and create empty file after 'unpack. 2020-06-11gnu: lyx: Wrap binary.Efraim Flashner Fixes <https://bugs.gnu.org/37147>. * gnu/packages/tex.scm (lyx)[arguments]: Import qt-utils. Add phase to wrap the lyx2.3 binary. 2020-06-02gnu: texlive-csquotes: Update source checksum.Marius Bakke This package had not been adjusted for the TeX Live 2019 upgrade. Fixes <https://bugs.gnu.org/41660>. * gnu/packages/tex.scm (texlive-csquotes)[simple-texlive-package]: Update expected checksum. 2020-06-01gnu: biber: Update to 2.12.Ludovic Courtès Fixes <https://bugs.gnu.org/41400>. Reported by Mikhail Tsykalov <tsymsh@gmail.com>. This essentially reverts 40fd909e3ddee2c46a27a4fe92ed49d3e7ffb413. This is a followup to the TeX Live 2019 update in 85892948bd9fb5fcc3409a60204cc8b14a4eb030. * gnu/packages/tex.scm (biber): Update to 2.12. 2020-04-30Merge branch 'master' into core-updatesMarius Bakke Conflicts: gnu/local.mk gnu/packages/backup.scm gnu/packages/emacs-xyz.scm gnu/packages/guile.scm gnu/packages/lisp.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/web.scm gnu/packages/xorg.scm 2020-04-27gnu: Add texlive-inconsolata.Ricardo Wurmus * gnu/packages/tex.scm (texlive-inconsolata): New variable. 2020-04-26Merge branch 'master' into core-updatesMarius Bakke 2020-04-25gnu: texlive-latex-pdfx: Fix typo.Matthew Kraai * gnu/packages/tex.scm (texlive-latex-pdfx)[description]: Fix typo. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> 2020-04-24Merge branch 'master' into core-updatesMarius Bakke 2020-04-24gnu: biber: Downgrade to 2.11.Ludovic Courtès Biber 2.12 is incompatible with biblatex 3.11, which is what's currently packaged. This is a followup to 41a010875ba4108e666f11fc111cf5bb5dcf5464. * gnu/packages/tex.scm (biber): Downgrade to 2.11. 2020-04-24gnu: biber: Address test failures.Ludovic Courtès * gnu/packages/patches/biber-sortinithash.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/tex.scm (biber)[source]: Use it. 2020-04-24gnu: Add texlive-csquotes.Ricardo Wurmus * gnu/packages/tex.scm (texlive-csquotes): New variable. 2020-04-23gnu: Add texlive-marginnote.Ricardo Wurmus * gnu/packages/tex.scm (texlive-marginnote): New variable. 2020-04-08Merge branch 'master' into core-updatesMarius Bakke Conflicts: etc/news.scm gnu/local.mk gnu/packages/check.scm gnu/packages/cross-base.scm gnu/packages/gimp.scm gnu/packages/java.scm gnu/packages/mail.scm gnu/packages/sdl.scm gnu/packages/texinfo.scm gnu/packages/tls.scm gnu/packages/version-control.scm 2020-04-04gnu: rubber: Make some inputs native.Vincent Legoll * gnu/packages/tex.scm (rubber)[inputs]: Move texinfo from here... [native-inputs]: ...to this new field. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>