aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-12-31 14:27:12 +0800
committer宋文武 <iyzsong@member.fsf.org>2025-01-01 10:48:34 +0800
commit4e9e63b09b9737ef09ddcb2cd739f18ba4cb71b4 (patch)
treee6de0d6e46f7ef45b41404fa33c6470ff4bddf73
parent806f52961f677ef45c95f1eded10880ac8089130 (diff)
downloadguix-4e9e63b09b9737ef09ddcb2cd739f18ba4cb71b4.tar.gz
guix-4e9e63b09b9737ef09ddcb2cd739f18ba4cb71b4.zip
gnu: xfce4-timer-plugin: Update to 1.7.3.
* gnu/packages/xfce.scm (xfce4-timer-plugin): Update to 1.7.3. [source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: I4364e3e6a8c0b4d530a0f7df7514afc08cfc96b0
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 075e62f0db..7a7aabc0fe 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -2197,24 +2197,24 @@ time.")
(define-public xfce4-timer-plugin
(package
- (name "xfce4-timer-plugin")
- (version "1.7.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
- "xfce4-timer-plugin/"
- (version-major+minor version)
- "/xfce4-timer-plugin-" version ".tar.bz2"))
- (sha256
- (base32
- "0zcbqpsyzzmbyv8cgd5wriqaigfpdcia6h1md0bfh1cmsg1biczy"))))
+ (name "xfce4-timer-plugin")
+ (version "1.7.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/panel-plugins/"
+ name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1110s55h4lsspdmyl58cbzfy57gfh8871b1213xjgk3i3q7nmqgc"))))
(build-system gnu-build-system)
(native-inputs
- (list intltool pkg-config))
+ (list xfce4-dev-tools))
(inputs
(list libxfce4ui xfce4-panel))
- (home-page
- "https://goodies.xfce.org/projects/panel-plugins/xfce4-timer-plugin")
+ (home-page "https://docs.xfce.org/panel-plugins/xfce4-timer-plugin/")
(synopsis "Simple countdown and alarm plugin for the Xfce panel")
(description "This is a simple plugin that lets the user run an
alarm at a specified time or at the end of a specified countdown