aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-30 15:56:47 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-30 15:57:44 +0800
commit4e92ed625fdeda90f1abc07b7fdd2d5d6f7c83cb (patch)
treef40f14597db053715330f481311dc3215a5dabab
parent18a69ddbf3184ba82ec396e2a0fe5aa11d555f4d (diff)
downloadguix-4e92ed625fdeda90f1abc07b7fdd2d5d6f7c83cb.tar.gz
guix-4e92ed625fdeda90f1abc07b7fdd2d5d6f7c83cb.zip
gnu: bwa,bwa-pssm: Improve package style.
* gnu/packages/bioinformatics.scm (bwa)[arguments]: Use G-expression. (bwa-pssm)[arguments]: Use G-expression. Change-Id: I63dd0f13f337fbf84967f1ef1b6332ce3391ae97
-rw-r--r--gnu/packages/bioinformatics.scm51
1 files changed, 26 insertions, 25 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2b31a46ef8..eae0a29b90 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4271,24 +4271,24 @@ splice junctions between exons.")
"1vf3iwkzxqkzhcfz2q3qyvcv3jrvbb012qy21pfgjl8lv20ywfr1"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ;no "check" target
- #:make-flags (list "CFLAGS=-fcommon"
- (string-append "CC=" ,(cc-for-target)))
- #:phases
- (modify-phases %standard-phases
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (lib (string-append out "/lib"))
- (doc (string-append out "/share/doc/bwa"))
- (man (string-append out "/share/man/man1")))
- (install-file "bwa" bin)
- (install-file "libbwa.a" lib)
- (install-file "README.md" doc)
- (install-file "bwa.1" man))))
- ;; no "configure" script
- (delete 'configure))))
+ (list #:tests? #f ;no "check" target
+ #:make-flags #~(list "CFLAGS=-fcommon"
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (lib (string-append out "/lib"))
+ (doc (string-append out "/share/doc/bwa"))
+ (man (string-append out "/share/man/man1")))
+ (install-file "bwa" bin)
+ (install-file "libbwa.a" lib)
+ (install-file "README.md" doc)
+ (install-file "bwa.1" man))))
+ ;; no "configure" script
+ (delete 'configure))))
(inputs (list zlib))
(supported-systems '("x86_64-linux" "aarch64-linux"))
(home-page "https://bio-bwa.sourceforge.net/")
@@ -4306,7 +4306,8 @@ and more accurate. BWA-MEM also has better performance than BWA-backtrack for
(license license:gpl3+)))
(define-public bwa-pssm
- (package (inherit bwa)
+ (package
+ (inherit bwa)
(name "bwa-pssm")
(version "0.5.11")
(source (origin
@@ -4321,12 +4322,12 @@ and more accurate. BWA-MEM also has better performance than BWA-backtrack for
(build-system gnu-build-system)
(arguments
(substitute-keyword-arguments (package-arguments bwa)
- ((#:phases phases '%standard-phases)
- `(modify-phases ,phases
- (add-after 'unpack 'patch-C-error
- (lambda _
- (substitute* "pssm.c"
- (("inline int map") "int map"))))))))
+ ((#:phases phases #~%standard-phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'patch-C-error
+ (lambda _
+ (substitute* "pssm.c"
+ (("inline int map") "int map"))))))))
(inputs
(list gdsl zlib perl))
;; https://bwa-pssm.binf.ku.dk is down, and all Web Archived copies are