aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-10-27 03:30:22 -0400
committerMark H Weaver <mhw@netris.org>2014-10-27 03:35:02 -0400
commit4e2f98c5394c515a5849be3aad6d06e8ad89807b (patch)
tree305dbd1e111cb5e2746c5a5ee74c5a841868b692
parent6becfdff766c00469faa3455e7ab7eb9f64730ac (diff)
downloadguix-4e2f98c5394c515a5849be3aad6d06e8ad89807b.tar.gz
guix-4e2f98c5394c515a5849be3aad6d06e8ad89807b.zip
gnu: Add prefix to license imports in (gnu packages feh).
* gnu/packages/feh.scm: Import (guix licenses) with #:prefix license: to avoid importing 'imlib2' from both (gnu packages image) and (guix licenses).
-rw-r--r--gnu/packages/feh.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/feh.scm b/gnu/packages/feh.scm
index 3707a53957..84edad419e 100644
--- a/gnu/packages/feh.scm
+++ b/gnu/packages/feh.scm
@@ -24,7 +24,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (guix licenses))
+ #:use-module ((guix licenses) #:prefix license:))
(define-public feh
(package
@@ -61,5 +61,6 @@ actions.")
;; The license is really the Expat license, with additional wording in the
;; 2nd paragraph: "acknowledgment shall be given in the documentation and
;; software packages that this Software was used."
- (license (x11-style "file://COPYING"
- "See 'COPYING' in the distribution."))))
+ (license (license:x11-style
+ "file://COPYING"
+ "See 'COPYING' in the distribution."))))