aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 20:35:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:53 +0000
commit4e0335782da7918d0e36138a0a7afa208920d0e7 (patch)
tree31d7165aa535f421744e6dbbc2511a337c90f55a
parent5026779dcbea086b05588061105e128de4cad03a (diff)
downloadguix-4e0335782da7918d0e36138a0a7afa208920d0e7.tar.gz
guix-4e0335782da7918d0e36138a0a7afa208920d0e7.zip
gnu: Remove go-github-com-smartystreets-assertions.
Upstream is changed to https://github.com/smarty/assertions. * gnu/packages/golang-check.scm (go-github-com-smartystreets-assertions): Delete variable. Change-Id: Iafc9a609d34a5402ce8a2efccd48806a08851ae4
-rw-r--r--gnu/packages/golang-check.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index f2f25b3838..afcbb4cb71 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1060,38 +1060,6 @@ such as readers and writers that fail after N consecutive reads/writes.")
execution when a test fails.")
(license license:expat)))
-(define-public go-github-com-smartystreets-assertions
- (package
- (name "go-github-com-smartystreets-assertions")
- (version "1.13.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/smartystreets/assertions")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256 (base32 "0flf3fb6fsw3bk1viva0fzrzw87djaj1mqvrx2gzg1ssn7xzfrzr"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/smartystreets/assertions"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (unless
- ;; The tests fail when run with gccgo.
- (false-if-exception (search-input-file inputs "/bin/gccgo"))
- (apply (assoc-ref %standard-phases 'check) args)))))))
- (native-inputs
- (list go-github.com-smartystreets-gunit))
- (home-page "https://github.com/smartystreets/assertions")
- (synopsis "Assertions for testing with Go")
- (description "The @code{assertions} package provides convenient assertion
-functions for writing tests in Go.")
- (license license:expat)))
-
(define-public go-github-com-smartystreets-goconvey
(package
(name "go-github-com-smartystreets-goconvey")