aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAwesomeAdam54321 <adam.faiz@disroot.org>2023-03-31 13:19:29 -0500
committerjgart <jgart@dismail.de>2023-05-19 00:47:34 -0500
commit4d4b9a9c13b8b1273c4f3e54913582faccb19965 (patch)
tree351bf201211fefa5c67a0a83dd24be90b1e7f71c
parent321ae25a26986c4ac06e5c0c99d19e1c808da6ac (diff)
downloadguix-4d4b9a9c13b8b1273c4f3e54913582faccb19965.tar.gz
guix-4d4b9a9c13b8b1273c4f3e54913582faccb19965.zip
gnu: Add python-slugid.
* gnu/packages/python-xyz.scm (python-slugid): New variable. Co-authored-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 47cea7be6f..2ab72416af 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17349,6 +17349,36 @@ can also be used to get the exact location, font or color of the text.")
is made as zipfile like as possible.")
(license license:isc)))
+(define-public python-slugid
+ (package
+ (name "python-slugid")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/taskcluster/slugid.py")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h64p2jlqv6lsmw8h2j203kx3bhv72cwzpk5gdhsaamw30cp3h1i"))))
+ (build-system python-build-system)
+ (native-inputs (list python-nose))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs tests? #:allow-other-keys)
+ (when tests?
+ ;; The project uses tox to run the tests via nose.
+ (invoke "nosetests" "-v" "test.py")))))))
+ (home-page "http://taskcluster.github.io/slugid.py")
+ (synopsis "Module for Base64 encoded UUID v4 slugs")
+ (description "This package provides a module for generating v4
+UUIDs and encoding them into 22 character URL-safe base64 slug
+representation.")
+ (license license:mpl2.0)))
+
(define-public python-rich
(package
(name "python-rich")