aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-07-20 15:40:54 +0200
committerLudovic Courtès <ludo@gnu.org>2024-07-26 17:44:39 +0200
commit4c8997c12336803d9dcc7529e44acb6602260147 (patch)
treea9e107ae281559c84238c5330695d44ddcd756e6
parentc1907b39e89ccbe7fe7800428acc8cba791c70e3 (diff)
downloadguix-4c8997c12336803d9dcc7529e44acb6602260147.tar.gz
guix-4c8997c12336803d9dcc7529e44acb6602260147.zip
gnu: rr: Add ‘supported-systems’ field.
* gnu/packages/debug.scm (rr)[supported-systems]: New field. Change-Id: I6d93b1eae91fbe6c963e737afd6e5d2a30160ac1
-rw-r--r--gnu/packages/debug.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index d34b4fdf28..2cdf87e266 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -782,6 +782,10 @@ error reporting, better tracing, profiling, and a debugger.")
(list pkg-config ninja which))
(inputs
(list gdb capnproto python python-pexpect zlib))
+
+ ;; List of supported systems according to 'src/preload/raw_syscall.S'.
+ (supported-systems '("x86_64-linux" "i686-linux" "aarch64-linux"))
+
(home-page "https://rr-project.org/")
(synopsis "Record and replay debugging framework")
(description