aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-06 13:34:11 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 17:03:09 +0100
commit4ba88b2d72a6143eee9a05bcd166d17cc2b1ac78 (patch)
treee177150a548846f28c17c9f60c58d1821d78d613
parentfcfe95b0770cb4daeebe1730511a1d665a808c89 (diff)
downloadguix-4ba88b2d72a6143eee9a05bcd166d17cc2b1ac78.tar.gz
guix-4ba88b2d72a6143eee9a05bcd166d17cc2b1ac78.zip
gnu: Add python-sunkit-image.
* gnu/packages/astronomy.scm (python-sunkit-image): New variable. Change-Id: I3213dc2dc2be23407db9316f5ed84a9d248cbee2
-rw-r--r--gnu/packages/astronomy.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 58d30c6720..75b21ae331 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1560,6 +1560,50 @@ instruments.")
(license (list license:bsd-3 ; licenses/LICENSE.rst, same as python-astropy
license:expat)))) ; licenses/KOSMOS_LICENSE
+(define-public python-sunkit-image
+ (package
+ (name "python-sunkit-image")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sunkit_image" version))
+ (sha256
+ (base32 "1wzii7dy0yb2lx0k8m3iak5vxc0wbybj5cdkvrk93sr14k9crqds"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; XXX: Check with upstram: assert False.
+ #:test-flags #~(list "-k" "not test_fnrgf")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ (lambda _
+ ;; For tests: Permission denied: '/homeless-shelter'
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-astropy
+ python-matplotlib
+ python-numpy
+ python-scikit-image
+ python-scipy
+ python-sunpy))
+ (native-inputs
+ (list python-astroscrappy
+ python-beautifulsoup4
+ python-dask
+ python-drms
+ python-importlib-resources
+ python-pytest-astropy
+ python-pytest-mpl
+ python-setuptools-scm
+ python-zeep))
+ (home-page "https://github.com/sunpy/sunkit-image/")
+ (synopsis "Solar Physics image processing toolbox")
+ (description
+ "This package provides an image processing toolbox for Solar Physics.")
+ (license license:bsd-2)))
+
(define-public wcslib
(package
(name "wcslib")