aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-26 12:11:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-03 16:59:42 +0100
commit4b19b18cda01f1c94f75281bc9c615b58eb7a423 (patch)
tree3762ac140f69847d4f6b9ff9191252d7564ff754
parentec8709d5ebe9c12c3d71c276e35b6e6574007ee1 (diff)
downloadguix-4b19b18cda01f1c94f75281bc9c615b58eb7a423.tar.gz
guix-4b19b18cda01f1c94f75281bc9c615b58eb7a423.zip
gnu: Add r-webfakes.
* gnu/packages/cran.scm (r-webfakes): New variable. Change-Id: Ia7bcf571bfbefe046b6fbd129a969fd118cf0760
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8ee35313e6..b6b48b9950 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7199,6 +7199,29 @@ in R and Shiny via the D3 visualization library.")
;; 3-clause BSD license.
(license (list license:gpl3+ license:bsd-3)))))
+(define-public r-webfakes
+ (package
+ (name "r-webfakes")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "webfakes" version))
+ (sha256
+ (base32 "0c4ja653fzamafkz7chfv16f1h7iibah683ma8sk2yaayywp7j47"))))
+ (properties `((upstream-name . "webfakes")))
+ (build-system r-build-system)
+ (native-inputs (list r-curl r-testthat))
+ (home-page "https://webfakes.r-lib.org/")
+ (synopsis "Fake web apps for HTTP testing")
+ (description
+ "This package lets you create a web app that makes it easier to test web
+clients without using the internet. It includes a web app framework with path
+matching, parameters and templates. It can parse various HTTP request bodies.
+It can send JSON data or files from the disk. It includes a web app that
+implements the httpbin.org web service.")
+ (license license:expat)))
+
(define-public r-wesanderson
(package
(name "r-wesanderson")
"signature-case corrupt-signature"): New tests. Ludovic Courtès 2013-12-29Add (guix pki)....* guix/pki.scm, tests/pki.scm: New files. * Makefile.am (MODULES): Add 'guix/pki.scm'. (SCM_TESTS): Add 'tests/pki.scm'. Ludovic Courtès