aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-10 21:39:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-11 01:03:21 +0100
commit490c6d4b034c962f7d47cf8fd342509289743b7a (patch)
treedd2c1a49eaa239d70eae766cc6bf40037dbb5a1e
parent3d3003badee5286dc8a2850983854330f3aacfab (diff)
downloadguix-490c6d4b034c962f7d47cf8fd342509289743b7a.tar.gz
guix-490c6d4b034c962f7d47cf8fd342509289743b7a.zip
gnu: Add r-downlit.
* gnu/packages/cran.scm (r-downlit): New variable.
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dca6c75e17..4082644bbf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26683,3 +26683,34 @@ drawing library. The ragg package provides a set of graphic devices based on
AGG to use as alternative to the raster devices provided through the
@code{grDevices} package.")
(license license:expat)))
+
+(define-public r-downlit
+ (package
+ (name "r-downlit")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "downlit" version))
+ (sha256
+ (base32
+ "0z4fz7c9kyd9v72wl3iqs2wxspi975d6b0rgjr9lvg8a18maa9z6"))))
+ (properties `((upstream-name . "downlit")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-brio" ,r-brio)
+ ("r-digest" ,r-digest)
+ ("r-evaluate" ,r-evaluate)
+ ("r-fansi" ,r-fansi)
+ ("r-rlang" ,r-rlang)
+ ("r-vctrs" ,r-vctrs)
+ ("r-yaml" ,r-yaml)))
+ (home-page "https://downlit.r-lib.org/")
+ (synopsis "Syntax highlighting and automatic linking")
+ (description
+ "This package provides syntax highlighting of R code, specifically
+designed for the needs of RMarkdown packages like @code{pkgdown},
+@code{hugodown}, and @code{bookdown}. It includes linking of function calls
+to their documentation on the web, and automatic translation of ANSI escapes
+in output to the equivalent HTML.")
+ (license license:expat)))