aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-11-14 20:21:06 +0000
committerAndreas Enge <andreas@enge.fr>2024-11-22 20:18:55 +0100
commit48cd10829088cdba6f44dad9808e37a687b8398e (patch)
treed6f2648ac3d30f14f95b374a7b75f3fdf56b37f7
parent296425c765efcd352b061e24356e7009f78d178e (diff)
downloadguix-48cd10829088cdba6f44dad9808e37a687b8398e.tar.gz
guix-48cd10829088cdba6f44dad9808e37a687b8398e.zip
gnu: dune-functions: Update to 2.10.0.
* gnu/packages/maths.scm (dune-functions): Update to 2.10.0. Change-Id: I022a75f9c66adf50b5b074594d50eed98f316634 Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bcc8f9f9eb..9257a8adb7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8805,17 +8805,15 @@ operating on statically typed trees of objects.")
(define-public dune-functions
(package
(name "dune-functions")
- (version "2.9.0")
+ (version "2.10.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.dune-project.org/staging/dune-functions.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://dune-project.org/download/"
+ version "/dune-functions-" version ".tar.gz"))
(sha256
(base32
- "0pmi9vk0pdq9qp3xvknsndg8l6f2xkjr1rwbfbzsl9aj0qv9rn2p"))))
+ "1v2yyiqacspa7fkz5pbhd9hcz8rk5bhyhlhwvr3jjgmniiy0x2hp"))))
(build-system cmake-build-system)
(arguments
`(#:phases