aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:20:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:09 +0200
commit48327e12bde22d31d7a5e07fbb5c8a63b6d5ca73 (patch)
tree3e58c5c36cf1e8655d7bde0cf2702f12ab61e31e
parentb9f894f044757638c24ea0be217c7abcd6f4d965 (diff)
downloadguix-48327e12bde22d31d7a5e07fbb5c8a63b6d5ca73.tar.gz
guix-48327e12bde22d31d7a5e07fbb5c8a63b6d5ca73.zip
gnu: Add texlive-genealogy.
* gnu/packages/tex.scm (texlive-genealogy): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 058d7db2f6..9fe1c84d79 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12911,6 +12911,29 @@ provides an environment like @code{eqnarray}, a @code{newtheorem}-like
environment (NewTheorem), and several macros.")
(license license:isc)))
+(define-public texlive-genealogy
+ (package
+ (name "texlive-genealogy")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/genealogy/"
+ "fonts/source/public/genealogy/"
+ "fonts/tfm/public/genealogy/")
+ (base32
+ "155ifff77s5cwjk1gkib7gcdx1mcrzzbca35mm8f9w5rzg1d5x7k")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (native-inputs (list texlive-metafont))
+ (home-page "https://ctan.org/pkg/genealogy")
+ (synopsis "Compilation of genealogy fonts")
+ (description
+ "This package provides a simple compilation of the genealogical symbols
+found in the @code{wasy} and @code{gen} fonts, adding the male and female
+symbols to Knuth's @code{gen} font, and so avoiding loading two fonts when you
+need only genealogical symbols. The font is distributed as Metafont source.")
+ (license license:lppl)))
+
(define-public texlive-geschichtsfrkl
(package
(name "texlive-geschichtsfrkl")