aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-05-23 17:03:34 +0000
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-30 15:44:36 +0800
commit471c4322df712efc3e4b48afe270d9470aa6e1c1 (patch)
tree260713b79266e3badcbb82530e148ed0a97b9d54
parent6efd02551d19b6d792f1a257251c3f104b07c857 (diff)
downloadguix-471c4322df712efc3e4b48afe270d9470aa6e1c1.tar.gz
guix-471c4322df712efc3e4b48afe270d9470aa6e1c1.zip
gnu: bwa: Update to 0.7.18.
* gnu/packages/bioinformatics.scm (bwa): Update to 0.7.18. [source]: Switch to git-fetch. [supported-systems]: Add aarch64-linux. Change-Id: I63dd0f13f337fbf84967f1ef1b6332ce3391ae97
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 063017a8aa..a07b6d376e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2022, 2023, 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2024 Alexis Simon <alexis.simon@runbox.com>
+;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4258,15 +4259,16 @@ splice junctions between exons.")
(define-public bwa
(package
(name "bwa")
- (version "0.7.17")
+ (version "0.7.18")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/lh3/bwa/releases/download/v"
- version "/bwa-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lh3/bwa")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1zfhv2zg9v1icdlq4p9ssc8k01mca5d1bd87w71py2swfi74s6yy"))))
+ "1vf3iwkzxqkzhcfz2q3qyvcv3jrvbb012qy21pfgjl8lv20ywfr1"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ;no "check" target
@@ -4284,12 +4286,10 @@ splice junctions between exons.")
(install-file "libbwa.a" lib)
(install-file "README.md" doc)
(install-file "bwa.1" man))))
- ;; no "configure" script
- (delete 'configure))))
+ ;; no "configure" script
+ (delete 'configure))))
(inputs (list zlib))
- ;; Non-portable SSE instructions are used so building fails on platforms
- ;; other than x86_64.
- (supported-systems '("x86_64-linux"))
+ (supported-systems '("x86_64-linux" "aarch64-linux"))
(home-page "https://bio-bwa.sourceforge.net/")
(synopsis "Burrows-Wheeler sequence aligner")
(description