aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-09 00:40:18 +0100
committerChristopher Baines <mail@cbaines.net>2023-10-11 12:11:42 +0100
commit46bdcee9c8480bf383424a0d68b2c9f54e818672 (patch)
tree3b169e0cbc06d974dfd7bd14b6f2d43acbbdccc1
parent514aec435652e37bd4debc6d665f0777c291e967 (diff)
downloadguix-46bdcee9c8480bf383424a0d68b2c9f54e818672.tar.gz
guix-46bdcee9c8480bf383424a0d68b2c9f54e818672.zip
gnu: python-stdatamodels: Update packages style.
* gnu/packages/astronomy.scm (python-stdatamodels): Update indentation to improve readability of the package. [description]: Add TexInfo styling bits. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/astronomy.scm55
1 files changed, 29 insertions, 26 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5f8ee2284e..fdf3f7d4e2 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2618,40 +2618,43 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(package
(name "python-stdatamodels")
(version "1.8.3")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "stdatamodels" version))
- (sha256
- (base32
- "0265xa9nrp6qp1z7v9kmnd3c8jc0dad2vzin657clk3rrsj2qll5"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "stdatamodels" version))
+ (sha256
+ (base32 "0265xa9nrp6qp1z7v9kmnd3c8jc0dad2vzin657clk3rrsj2qll5"))))
(build-system pyproject-build-system)
(arguments
(list
- ;; Disable tests requiring access to CRDS servers to download ~500MiB
- ;; of data.
+ ;; Disable tests requiring access to CRDS servers to download ~500MiB of
+ ;; data.
#:test-flags #~(list "-k" "not test_crds_selectors_vs_datamodel")
- #:phases #~(modify-phases %standard-phases
- (add-before 'check 'set-home
- (lambda _
- (setenv "HOME" "/tmp"))))))
- (propagated-inputs (list python-asdf
- python-asdf-astropy
- python-astropy
- python-numpy
- python-psutil))
- (native-inputs (list python-crds
- python-pytest
- python-pytest-doctestplus
- python-scipy
- python-semantic-version
- python-setuptools-scm))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-asdf
+ python-asdf-astropy
+ python-astropy
+ python-numpy
+ python-psutil))
+ (native-inputs
+ (list python-crds
+ python-pytest
+ python-pytest-doctestplus
+ python-scipy
+ python-semantic-version
+ python-setuptools-scm))
(home-page "https://github.com/spacetelescope/stdatamodels")
(synopsis
"Core support for DataModel classes used in calibration pipelines")
(description
- "Provides DataModel, which is the base class for data models implemented in
-the @acronym{JWST, James Webb Space Telescope} and @acronym{Roman, Nancy Grace
-Roman Space Telescope} calibration software.")
+ "Provides @code{DataModel}, which is the base class for data models
+implemented in the @acronym{JWST, James Webb Space Telescope} and
+@acronym{Roman, Nancy Grace Roman Space Telescope} calibration software.")
(license license:bsd-3)))
(define-public python-stpipe