aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-31 16:14:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:22:14 +0200
commit45f27d18740f8cb958b5a36fc89bff33cef7f54a (patch)
tree1f7eee626cacb726217648bd45ae4d0e042de21d
parent7d991e4e7ba5da5100b8544c00adefaa52871e6e (diff)
downloadguix-45f27d18740f8cb958b5a36fc89bff33cef7f54a.tar.gz
guix-45f27d18740f8cb958b5a36fc89bff33cef7f54a.zip
gnu: Remove rust-ecdsa-0.14.
* gnu/packages/crates-crypto.scm (rust-ecdsa-0.14): Delete variable. Change-Id: I22f06a0c2d9df694e224f57ac3fc9e54be1749da
-rw-r--r--gnu/packages/crates-crypto.scm22
1 files changed, 0 insertions, 22 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index e88835b252..48bcd1badb 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -2184,28 +2184,6 @@ Signature Standard), providing RFC6979 deterministic signatures as well as
support for added entropy.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-ecdsa-0.14
- (package
- (inherit rust-ecdsa-0.16)
- (name "rust-ecdsa")
- (version "0.14.8")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "ecdsa" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0p1wxap2s6jm06y2w3cal8dkz6p9223ir9wws70rgx8h929h2cs1"))))
- (arguments
- `(#:cargo-inputs (("rust-der" ,rust-der-0.6)
- ("rust-elliptic-curve" ,rust-elliptic-curve-0.12)
- ("rust-rfc6979" ,rust-rfc6979-0.3)
- ("rust-serdect" ,rust-serdect-0.1)
- ("rust-signature" ,rust-signature-1))
- #:cargo-development-inputs (("rust-elliptic-curve" ,rust-elliptic-curve-0.12)
- ("rust-hex-literal" ,rust-hex-literal-0.3)
- ("rust-sha2" ,rust-sha2-0.10))))))
-
(define-public rust-ecies-ed25519-0.5
(package
(name "rust-ecies-ed25519")