aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 03:56:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 04:36:51 +0200
commit44da87334da74cbbeb20e5819c767fc886cf7aac (patch)
treec112b1b9b7e7dc31a6a2c32927e7e2fce940c557
parent110888f85f21df6922d4042926d25c567fa0d966 (diff)
downloadguix-44da87334da74cbbeb20e5819c767fc886cf7aac.tar.gz
guix-44da87334da74cbbeb20e5819c767fc886cf7aac.zip
gnu: electron-cash: Fix share/ location.
* gnu/packages/finance.scm (electron-cash)[arguments]: Drop bogus ‘local/share’ subdirectory: rename ‘patch-home’ to ‘create-output-directories’ and adjust body to match.
-rw-r--r--gnu/packages/finance.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 6ffdff5d6e..12da4225dc 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -517,11 +517,10 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(guix build qt-utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-home
+ (add-after 'unpack 'create-output-directories
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "setup.py"
- (("~/.local/share")
- (string-append (assoc-ref outputs "out") "/local/share")))
+ ;; setup.py installs to ~/.local/share if this doesn't exist.
+ (mkdir-p (string-append (assoc-ref outputs "out") "/share"))
#t))
(add-after 'unpack 'use-libsecp256k1-input
(lambda* (#:key inputs #:allow-other-keys)
ecify builder code to be run when building a user environment with ‘guix-package’. For instance, Texinfo’s hook would create a new ‘dir’. ** extend ‘propagated-build-inputs’ with support for multiple outputs #+BEGIN_SRC scheme (outputs '("out" "include")) (propagated-build-inputs `(((("i1" ,p1 "o1") ("i2" ,p2)) => "include") ("i3" ,p3))) #+END_SRC * synchronize non-GNU package descriptions with the [[http://directory.fsf.org][FSD]] Meta-data for GNU packages, including descriptions and synopses, can be dumped from the FSD: http://directory.fsf.org/wiki?title=GNU/Export&action=purge . We could periodically synchronize with that. * add a guildhall build system The Guildhall is Guile’s packaging system. It should be easy to add a ‘guildhall-build-system’ that does the right thing based on guildhall recipes. * union Support sophisticated collision handling when building a union: honor per-package priorities, etc. * add GUIX_ALLOW_EXPENSIVE_TESTS Tests that need to download stuff or otherwise take a long time would only be run when that is defined. * guix build utils ** MAYBE Change ‘ld-wrapper’ to add RPATH for libs passed by file name ** MAYBE Add equivalent to chrpath that uses [[https://gitorious.org/guile-dlhacks/guile-dlhacks/][guile-dlhacks]] ** MAYBE Add a hash-rewriting thing for deep dependency replacement without rebuild See [[https://github.com/NixOS/nixpkgs/commit/d1662d715514e6ef9d3dc29f132f1b3d8e608a18][Shea Levy's `replace-dependency' in Nixpkgs]]. * distro ** port to GNU/Hurd, aka. ‘i686-gnu’ Problems include that current glibc releases do not build on GNU/Hurd. In addition, there haven’t been stable releases of GNU Mach, MiG, and Hurd, which would be a pre-condition. * Installer ** Fix impossibility to restart on error after cow-store has been started See https://lists.gnu.org/archive/html/guix-devel/2018-12/msg00161.html. - Force reboot upon installer failure - Unshare the installer process - Run the installer process in a separate namespace ** Partitioning *** Add RAID support *** Add more partitioning schemes The actual schemes are taken from Debian Installer but some are not implemented yet: like "Separate partitions for /home /var and /tmp". *** Replace wait page "Partition formating is in progress, please wait" Create a new waiting page describing what's being done: [ 20% ] Running mkfs.ext4 on /dev/sda2 ... [ 40% ] Running mkfs.ext4 on /dev/sda3 ... *** Add a confirmation page before formating/partitioning ** Desktop environments *** Allow for no desktop environments Propose to choose between "headless server" and "lightweight X11" in a new page. *** Add services selection feature Add a services page to the configuration. Ask for services to be installed like SSH, bluetooth, TLP in a checkbox list? ** Locale and keymap *** Try to guess user locale and keymap by probing BIOS or HW (dmidecode) ** Timezone *** Regroup everything in one single page Under the form: (UTC + 1) Europe/Paris (UTC + 2) Africa/Cairo ... ** Display issue *** Investigate display issue described here: https://lists.gnu.org/archive/html/guix-devel/2019-01/msg00305.html