aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-10 09:44:39 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:46 +0000
commit44201dc715e83ba0b3e8cb6a0b8082cae842e19e (patch)
tree4b587992a326d259c69b1d756e53fda1b6bb8947
parent799c56265fdbc3c68c262d5b55b201745dc27642 (diff)
downloadguix-44201dc715e83ba0b3e8cb6a0b8082cae842e19e.tar.gz
guix-44201dc715e83ba0b3e8cb6a0b8082cae842e19e.zip
gnu: python-mistune: Update to 3.0.2.
* gnu/packages/python-xyz.scm (python-mistune): Update to 3.0.2. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ia04fb0e249fe97ba2e4bf8123aeb340a8ec70953
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b18bb3c4a6..c8cc2e150e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15557,17 +15557,18 @@ It also removes useless @code{pass} statements.")
(define-public python-mistune
(package
(name "python-mistune")
- (version "0.8.4")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "mistune" version))
(sha256
(base32
- "0vkmsh0x480rni51lhyvigfdf06b9247z868pk3bal1wnnfl58sr"))))
- (build-system python-build-system)
+ "1s4ba1m69yldrhnyfj8lm4bl3axbi95g1dicxya27j9hv7g96zzw"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-nose python-cython))
+ (list python-setuptools
+ python-wheel))
(home-page "https://github.com/lepture/mistune")
(synopsis "Markdown parser in pure Python")
(description "This package provides a fast markdown parser in pure