aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:53:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:35 +0200
commit433d03b36c758ef11043c1839c52454119d58d21 (patch)
treeed57a46ce198da0b9b90bb1901bb27fce7513ce2
parent683fa2838a3c84c90197d1fb3f09a8062513f8e4 (diff)
downloadguix-433d03b36c758ef11043c1839c52454119d58d21.tar.gz
guix-433d03b36c758ef11043c1839c52454119d58d21.zip
gnu: Add texlive-eqnnumwarn.
* gnu/packages/tex.scm (texlive-eqnnumwarn): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6c74070fcb..3821a0e6d9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3472,6 +3472,28 @@ environment. This environment is similar, in some ways, to the @code{align}
environment of @code{amsmath}.")
(license license:gpl3)))
+(define-public texlive-eqnnumwarn
+ (package
+ (name "texlive-eqnnumwarn")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/eqnnumwarn/"
+ "tex/latex/eqnnumwarn/")
+ (base32
+ "06z6rb0q5qln5knamwxljzw5h373r2xh159ml9akw4kb2cdk3bri")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/eqnnumwarn")
+ (synopsis "Warn for a displaced equation number")
+ (description
+ "Sometimes an equation is too long that an equation number will be
+typeset below the equation itself, but yet not long enough to yield an
+@samp{overfull \\hbox} warning. The @code{eqnnumwarn} package modifies the
+standard @code{amsmath} numbered equation environments to throw a warning
+whenever this occurs.")
+ (license license:lppl1.3+)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")