aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:30:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:57 +0200
commit42d9e08f9edddc7470263636d93695e975c7150b (patch)
tree590c54dcba5f35338c93e9023c57974b808ab0ff
parentca2240524ee6219d2f1097fce2446f0853841fe1 (diff)
downloadguix-42d9e08f9edddc7470263636d93695e975c7150b.tar.gz
guix-42d9e08f9edddc7470263636d93695e975c7150b.zip
gnu: Add texlive-mattens.
* gnu/packages/tex.scm (texlive-mattens): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 33c63ee9fc..df4067044b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4670,6 +4670,27 @@ content of the whole matrix. Furthermore, @code{matrix-skeleton} provides
rows and columns for easy styling.")
(license license:isc)))
+(define-public texlive-mattens
+ (package
+ (name "texlive-mattens")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mattens/" "source/latex/mattens/"
+ "tex/latex/mattens/")
+ (base32
+ "18v2hypd9vkxk3anixvgf16rmsjzq3apm6s7qxrkk4vyrgrahsnj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mattens")
+ (synopsis "Matrices and tensor typesetting")
+ (description
+ "The @code{mattens} package contains the definitions to typeset matrices,
+vectors and tensors as used in the engineering community for the
+representation of common vectors and tensors such as forces, velocities,
+moments of inertia, etc.")
+ (license license:lppl1.3c)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")