aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:08 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:13:13 +0100
commit4026402553b9fb0418960ad5e67f6c6a90c6c2f1 (patch)
treef9c12680965f3af07b70aa4e91bc9e919c804c74
parent490def939412143c4b94f02a15a601ba289dfe9b (diff)
downloadguix-4026402553b9fb0418960ad5e67f6c6a90c6c2f1.tar.gz
guix-4026402553b9fb0418960ad5e67f6c6a90c6c2f1.zip
gnu: Add perl-config-simple.
* gnu/packages/perl.scm (perl-config-simple): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 702369caf7..3cd2a34d3d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2163,6 +2163,28 @@ power move up to @code{Config::Simple}, @code{Config::General} or one of the
many other @code{Config::*} modules.")
(license license:perl-license)))
+(define-public perl-config-simple
+ (package
+ (name "perl-config-simple")
+ (version "4.58")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SH/SHERZODR/Config-Simple-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1d7dhvis1i03xlj8z3g5l8mz88kf7dn13zngbjhq94qgdxq9b6fx"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Config-Simple")
+ (synopsis "Simple configuration file class")
+ (description
+ "@code{Config::Simple} is a class representing configuration file object.
+It supports several configuration file syntax and tries to identify the file
+syntax automatically. The library supports parsing, updating and creating
+configuration files.")
+ (license license:perl-license)))
+
(define-public perl-const-fast
(package
(name "perl-const-fast")