aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-13 23:49:54 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-23 19:00:10 +0300
commit3feaac67a3426c7412e845f1ad9e6596235a3586 (patch)
treed1f16bacbd84289d2c185091a4fed71bca43b713
parent8333938605e0d7e4f117ca41c5e0f9c23a5ccdee (diff)
downloadguix-3feaac67a3426c7412e845f1ad9e6596235a3586.tar.gz
guix-3feaac67a3426c7412e845f1ad9e6596235a3586.zip
gnu: bootterm: Use GEXPs.
* gnu/packages/terminals.scm (bootterm): Use GEXPs. Change-Id: I6c718e57eba9304fde8c4ed1fa2f00cf20d44051
-rw-r--r--gnu/packages/terminals.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 19b667107f..6cf0d01607 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1731,19 +1731,18 @@ terminal. Note that you need support for OpenGL 3.2 or higher.")
"1xag6agcqkq2p7gp20qxjb95ah7p6lia65jmm5v51rqxfzclx2h1"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no test suite
- #:make-flags (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- ;; No ./configure script
- (delete 'configure)
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/" ,name "-" ,version)))
- (install-file "README.md" doc)
- #t))))))
+ (list #:tests? #f ; no test suite
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; No ./configure script
+ (delete 'configure)
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" #$name "-" #$version)))
+ (install-file "README.md" doc)))))))
(home-page "https://github.com/wtarreau/bootterm")
(synopsis "Serial terminal")
(description "Bootterm is a terminal designed to ease connection to