aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:30 +0200
commit3f61a6979fb5416de3b8f3a2e88ed9f327bf7062 (patch)
treecd28d05abfebe4b292795ea62a62e1c413042ef0
parent5240a2136dbba8b1b426bbda4120275102d0dbd9 (diff)
downloadguix-3f61a6979fb5416de3b8f3a2e88ed9f327bf7062.tar.gz
guix-3f61a6979fb5416de3b8f3a2e88ed9f327bf7062.zip
gnu: Add texlive-subeqnarray.
* gnu/packages/tex.scm (texlive-subeqnarray): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d45179fa89..6f292f696e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96723,6 +96723,31 @@ solves this. Note that this package is not compatible with the package
@code{leqno} and @code{fleqn}.")
(license license:lppl)))
+(define-public texlive-subeqnarray
+ (package
+ (name "texlive-subeqnarray")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/subeqnarray/"
+ "source/latex/subeqnarray/"
+ "tex/latex/subeqnarray/")
+ (base32
+ "19jv7sl6p1kshv13wk813lndb9fjr4bf2rf4s1ffd0l253mmxch6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/subeqnarray")
+ (synopsis "Equation array with sub numbering")
+ (description
+ "This package defines the @code{subeqnarray} and @code{subeqnarray*}
+environments, which behave like the corresponding @code{eqnarray} and
+@code{eqnarray*} environments, except that the individual lines are numbered
+like @samp{1a}, @samp{1b}, etc. To refer to these numbers an extra label
+command @code{\\slabel} is provided. Users are urged to consider the
+alignment capabilities of the @code{amsmath} bundle, which produce better
+results than @code{eqnarray}-related macros.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar