aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-11-03 09:28:07 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2025-02-13 00:07:21 +0900
commit3f135b6ce03ba22d8b227343dca702a4228b45cf (patch)
treeb094b391edd1f0b02e52e313754f520ba58b780e
parentae17a601d91af6cb8df27c527bc65dbe385480f2 (diff)
downloadguix-3f135b6ce03ba22d8b227343dca702a4228b45cf.tar.gz
guix-3f135b6ce03ba22d8b227343dca702a4228b45cf.zip
gnu: tinygltf: Install a library.
Previously, only a static library would be produced and then deleted in a phase. * gnu/packages/graphics.scm (tinygltf) [arguments]: Add #:configure-flags. <phases>: Remove delete-static-lib. Change-Id: I019a87a4fbf68fc19270a41d58af3a2184b77215
-rw-r--r--gnu/packages/graphics.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index bb5df59b70..df2d287eb8 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2611,6 +2611,7 @@ and build scripts for the OpenXR loader.")
(build-system cmake-build-system)
(arguments
(list
+ #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'use-our-packages
@@ -2623,10 +2624,6 @@ and build scripts for the OpenXR loader.")
"stb_image_write.h")
(symlink (search-input-file inputs "include/catch.hpp")
"catch.hpp")))
- (add-after 'install 'delete-static-lib
- (lambda _
- (delete-file (string-append #$output
- "/lib/libtinygltf.a"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(if tests?