aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-06-22 18:06:04 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:12 +0800
commit3e43f7a57102ef65b06263d2e97e1bfbb3b56a35 (patch)
tree0360bed1dd015639cae31bec20c32498993f7b34
parentb07afb5f5398ea0716c076734e8bcd5c7626b803 (diff)
downloadguix-3e43f7a57102ef65b06263d2e97e1bfbb3b56a35.tar.gz
guix-3e43f7a57102ef65b06263d2e97e1bfbb3b56a35.zip
gnu: fcitx5-qt: Enable qt6 support.
* gnu/packages/fcitx5.scm (fcitx5-qt)[arguments]<#:configure-flags>: Add CMAKE_INSTALL_QT6PLUGINDIR and ENABLE_QT6=ON. [inputs]: Add qtbase, qtwayland, wayland. Change-Id: I389253eb08efe765d1c79c44ac5d69717ccaf362
-rw-r--r--gnu/packages/fcitx5.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index aba0be21e7..c555b8ab84 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2022 dan <i@dan.games>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -320,12 +321,18 @@ IM module for GTK+3 applications.
`(#:configure-flags
(list (string-append "-DCMAKE_INSTALL_QT5PLUGINDIR="
%output "/lib/qt5/plugins")
- "-DENABLE_QT4=Off")))
+ (string-append "-DCMAKE_INSTALL_QT6PLUGINDIR="
+ %output "/lib/qt6/plugins")
+ "-DENABLE_QT4=Off"
+ "-DENABLE_QT6=ON")))
(inputs
`(("fcitx5" ,fcitx5)
("libxcb" ,libxcb)
("libxkbcommon" ,libxkbcommon)
- ("qtbase" ,qtbase-5)
+ ("qtbase-5" ,qtbase-5)
+ ("qtbase" ,qtbase)
+ ("qtwayland" ,qtwayland)
+ ("wayland" ,wayland)
("gettext" ,gettext-minimal)))
(native-inputs
(list extra-cmake-modules))