aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-25 15:21:53 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:55 +0000
commit3e3b6202aa6290e6bf0631552b2e08cb63d3d36c (patch)
tree3df5a0cd2e78af19afc088e3444fc05583418cd7
parent8ee3669af48d78c919b42b124eb05d7d2bf2a2d0 (diff)
downloadguix-3e3b6202aa6290e6bf0631552b2e08cb63d3d36c.tar.gz
guix-3e3b6202aa6290e6bf0631552b2e08cb63d3d36c.zip
gnu: go-github-com-fsnotify-fsnotify: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-fsnotify-fsnotify): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I56f234c1dbb956f97d9d733bc9d7b5dd572830f8
-rw-r--r--gnu/packages/golang-xyz.scm25
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 00361fec30..59f9c633b8 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2870,6 +2870,31 @@ quoting, commenting, and escaping.")
(home-page "https://github.com/flynn-archive/go-shlex")
(license license:asl2.0))))
+(define-public go-github-com-fsnotify-fsnotify
+ (package
+ (name "go-github-com-fsnotify-fsnotify")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fsnotify/fsnotify")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h7vs21lkj4bqbw5a6mqykaf56y181r0nja7c8pzajkvbsc39y8m"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/fsnotify/fsnotify"))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://github.com/fsnotify/fsnotify")
+ (synopsis "File system notifications for Go")
+ (description
+ "File system notifications for Go")
+ (license license:bsd-3)))
+
(define-public go-github-com-fxamacker-cbor-v2
(package
(name "go-github-com-fxamacker-cbor-v2")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7dd5d93097..7f16568f86 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3329,30 +3329,6 @@ GNU extensions} to the POSIX recommendations for command-line options.")
all types of configuration needs and formats.")
(license license:expat)))
-(define-public go-github-com-fsnotify-fsnotify
- (package
- (name "go-github-com-fsnotify-fsnotify")
- (version "1.7.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/fsnotify/fsnotify")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1h7vs21lkj4bqbw5a6mqykaf56y181r0nja7c8pzajkvbsc39y8m"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/fsnotify/fsnotify"))
- (propagated-inputs
- `(("golang.org/x/sys" ,go-golang-org-x-sys)))
- (home-page "https://github.com/fsnotify/fsnotify")
- (synopsis "File system notifications for Go")
- (description "File system notifications for Go")
- (license license:bsd-3)))
-
(define-public go-github-com-nxadm-tail
(package
(name "go-github-com-nxadm-tail")