aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-05 13:44:56 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-05 17:32:17 +0400
commit3c4cf39736a519e10c123a2d3d73927cb9e0219c (patch)
tree048a5d07228d049de197f822ded2885a552b1e39
parent14be341953399e2b7656c118191d82f257c6021f (diff)
downloadguix-3c4cf39736a519e10c123a2d3d73927cb9e0219c.tar.gz
guix-3c4cf39736a519e10c123a2d3d73927cb9e0219c.zip
gnu: Add erlang-p1-acme.
* gnu/packages/erlang-xyz.scm (erlang-p1-acme): New variable. Change-Id: I2bd58524f1a41ef18971ccf7e4fb3fb5cc7e3cdf Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/erlang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 07837fde0b..f880612233 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -108,6 +108,33 @@ Erlang and Elixir.")
(home-page "https://hex.pm/packages/pkix")
(license license:asl2.0)))
+(define-public erlang-p1-acme
+ (package
+ (name "erlang-p1-acme")
+ (version "1.0.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "p1_acme" version))
+ (sha256
+ (base32 "0nfxs3ldgbh7a8r7wxl0gw98r1v50jaj54c0nw8fl8ixdvr9dqcc"))))
+ (build-system rebar-build-system)
+ (inputs (list erlang-base64url erlang-idna erlang-jiffy erlang-jose
+ erlang-yconf))
+ (native-inputs (list erlang-pc))
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-environment
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (synopsis "ACME client for Erlang")
+ (description "This package provides ACME client for Erlang.")
+ (home-page "https://hex.pm/packages/p1_acme")
+ (license license:asl2.0)))
+
(define-public erlang-p1-oauth2
(package
(name "erlang-p1-oauth2")