aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-16 12:10:06 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-16 12:10:21 +0000
commit3bd3a572fd48170df2e1fa82413cf2c95c719e1b (patch)
tree0a2c4ca44fc62f76254bbfa8460f6e8e394f2afb
parent5179e703665e78fc68f40356b783b5944094b60e (diff)
downloadguix-3bd3a572fd48170df2e1fa82413cf2c95c719e1b.tar.gz
guix-3bd3a572fd48170df2e1fa82413cf2c95c719e1b.zip
gnu: python-autograd-gamma: Fix build.
* gnu/packages/machine-learning.scm (python-autograd-gamma) [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I8d537670e50e2fbd571f69c4e20030686fa6e4ea
-rw-r--r--gnu/packages/machine-learning.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 1fe5923d79..badbcd6deb 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -167,7 +167,12 @@ representations and sentence classification.")
(sha256
(base32 "1i699a9m5ndnj8cwzjjf2agb77aawhzrzxfbmn5zrkxridxvnypj"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-autograd python-scipy))
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-autograd
+ python-scipy))
(home-page "https://github.com/CamDavidsonPilon/autograd-gamma")
(synopsis
"Autograd-compatible approximations to the gamma family of functions")