aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:18:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:14 +0200
commit3ae611e95fe09306e1b0dddd742098c33a41c81f (patch)
tree47d2627e5787b34a8ac459546b669041f8347c57
parent0fb4f2c801277f0b1657b868a79d741ea3fefe73 (diff)
downloadguix-3ae611e95fe09306e1b0dddd742098c33a41c81f.tar.gz
guix-3ae611e95fe09306e1b0dddd742098c33a41c81f.zip
gnu: Add texlive-typehtml.
* gnu/packages/tex.scm (texlive-typehtml): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 23012f5ea5..809c48ba15 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7377,6 +7377,26 @@ TeX metrics (VF and TFM files) and macros for use with LaTeX.")
(define-deprecated-package texlive-fonts-txfonts texlive-txfonts)
+(define-public texlive-typehtml
+ (package
+ (name "texlive-typehtml")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/typehtml/"
+ "source/latex/typehtml/"
+ "tex/latex/typehtml/")
+ (base32
+ "1nmdh2mhkzdqs5y4k95g9il6vz4rgndzhkikiilknkwg1a04rrzi")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/typehtml")
+ (synopsis "Typeset HTML directly from LaTeX")
+ (description
+ "This package typesets HTML directly from LaTeX. It can handle almost
+all of HTML2, and most of the math fragment of the draft HTML3.")
+ (license license:lppl)))
+
(define-public texlive-iwona
(package
(name "texlive-iwona")