aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-01 16:56:48 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-05 10:56:39 +0100
commit39d1a429fe48b1e3ee1530a22d60acde3c4d1077 (patch)
tree94ecaec5a4a52a9a74a218a0da2e75436aeec123
parent571f1fa3b2b0068fcc65e3a879cef37a87312a19 (diff)
downloadguix-39d1a429fe48b1e3ee1530a22d60acde3c4d1077.tar.gz
guix-39d1a429fe48b1e3ee1530a22d60acde3c4d1077.zip
gnu: kactivities: Move to tier 2.
KDE now lists this package as tier 2, I was trapped by the definitions being at the wrong place. * gnu/packages/kde-frameworks.scm (kactivities): Move into the "section" of tier 2 packages. (kactivities-stats) Remove now obsolete comment.
-rw-r--r--gnu/packages/kde-frameworks.scm92
1 files changed, 45 insertions, 47 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index f8eb504d80..beac86f597 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1320,6 +1320,51 @@ uses a job-based interface to queue tasks and execute them in an efficient way."
;; Tier 2 frameworks additionally depend on tier 1 frameworks, but still have
;; easily manageable dependencies.
+(define-public kactivities
+ (package
+ (name "kactivities")
+ (version "5.39.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0nkc1p7n6yvybcib6aqmnz08hwn3ryj1f9wbkiimgs0svr00sslq"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("boost" ,boost)
+ ("kauth" ,kauth)
+ ("kbookmarks" ,kbookmarks)
+ ("kcodecs" ,kcodecs)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kio" ,kio)
+ ("kitemviews" ,kitemviews)
+ ("kjobwidgets" ,kjobwidgets)
+ ("kservice" ,kservice)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("solid" ,solid)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Core components for the KDE Activity concept")
+ (description "KActivities provides the infrastructure needed to manage a
+user's activities, allowing them to switch between tasks, and for applications
+to update their state to match the user's current activity. This includes a
+daemon, a library for interacting with that daemon, and plugins for integration
+with other frameworks.")
+ ;; triple licensed
+ (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
+
(define-public kauth
(package
(name "kauth")
@@ -1862,53 +1907,6 @@ maintaining an index of the contents of your files.")
;; dual licensed
(license (list license:gpl2+ license:lgpl2.1+))))
-(define-public kactivities
- (package
- (name "kactivities")
- (version "5.39.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://kde/stable/frameworks/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0nkc1p7n6yvybcib6aqmnz08hwn3ryj1f9wbkiimgs0svr00sslq"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
- (inputs
- `(("boost" ,boost)
- ("kauth" ,kauth)
- ("kbookmarks" ,kbookmarks)
- ("kcodecs" ,kcodecs)
- ("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kio" ,kio)
- ("kitemviews" ,kitemviews)
- ("kjobwidgets" ,kjobwidgets)
- ("kservice" ,kservice)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("qtbase" ,qtbase)
- ("qtdeclarative" ,qtdeclarative)
- ("solid" ,solid)))
- (home-page "https://community.kde.org/Frameworks")
- (synopsis "Core components for the KDE Activity concept")
- (description "KActivities provides the infrastructure needed to manage a
-user's activities, allowing them to switch between tasks, and for applications
-to update their state to match the user's current activity. This includes a
-daemon, a library for interacting with that daemon, and plugins for integration
-with other frameworks.")
- ;; triple licensed
- (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
-
-;; NOTE: This package is listed as a tier 2 package even though it requires
-;; kactivities - a tier 3 package.
(define-public kactivities-stats
(package
(name "kactivities-stats")
his enables the use of the subdirs.el feature of Emacs, where specifying a directory in EMACSLOADPATH translates into a `load-path' variable containing the directory and all its sub-directories. * gnu/packages/aux-files/emacs/guix-emacs.el (guix-emacs-autoload-packages): Use `load-path' directly instead of parsing EMACSLOADPATH. Reported-by: Leo Prikler <leo.prikler@student.tugraz.at> Signed-off-by: Clément Lassieur <clement@lassieur.org> Maxim Cournoyer 2019-12-04gnu: emacs: Fix guix-emacs.el indentation.•••* gnu/packages/aux-files/emacs/guix-emacs.el: Fix indentation. Signed-off-by: Clément Lassieur <clement@lassieur.org> Maxim Cournoyer 2019-11-18gnu: emacs: Adapt the autoloads auxiliary code to use EMACSLOADPATH.•••The Elisp directories to scan for autoloads are now taken from EMACSLOADPATH instead of from the user profile, environment profile or system profile. Manually adding the Elisp directories to the `load-path' is no longer necessary, as this is covered by Emacs when they are in EMACSLOADPATH. The caching logic is also removed, as this code is not typically run often and the gain is marginal (loading autoloads files is cheap). * gnu/packages/aux-files/emacs/guix-emacs.el (guix-emacs-directory) (guix-emacs-subdirs, guix-emacs-directories): Remove procedures. (guix-emacs-find-autoloads): Filter the directory entries by passing the regexp to `directory-files' directly, which is ten times faster. Remove deduplication. (guix-emacs-autoloads-regexp): Remove the group, which used to filter out the file extension; it no longer works this way due to passing the regexp to the `directory-files' procedure directly, which doesn't care about groups. (guix-emacs-autoload-packages): Update doc. Search package directories from EMACSLOADPATH. Do not populate the load-path. Remove cache. Maxim Cournoyer 2019-10-01gnu: linux-libre: Add version 5.3.1.•••* gnu/packages/linux.scm (linux-libre-5.3-version) (linux-libre-5.3-pristine-source, linux-libre-5.3-source) (linux-libre-headers-5.3, linux-libre-5.3): New public variables. * gnu/packages/aux-files/linux-libre/5.3-arm.conf, gnu/packages/aux-files/linux-libre/5.3-arm-veyron.conf, gnu/packages/aux-files/linux-libre/5.3-arm64.conf, gnu/packages/aux-files/linux-libre/5.3-i686.conf, gnu/packages/aux-files/linux-libre/5.3-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them. Tobias Geerinckx-Rice 2019-09-18gnu: linux-libre: Enable all nftables families.•••* gnu/packages/aux-files/linux-libre/4.19-arm.conf, gnu/packages/aux-files/linux-libre/4.19-arm64.conf, gnu/packages/aux-files/linux-libre/4.19-i686.conf, gnu/packages/aux-files/linux-libre/4.19-x86_64.conf, gnu/packages/aux-files/linux-libre/5.2-arm.conf, gnu/packages/aux-files/linux-libre/5.2-arm64.conf, gnu/packages/aux-files/linux-libre/5.2-i686.conf, gnu/packages/aux-files/linux-libre/5.2-x86_64.conf: Set CONFIG_NF_TABLES_INET, CONFIG_NF_TABLES_NETDEV, CONFIG_NF_TABLES_IPV4, CONFIG_NF_TABLES_IPV6 and CONFIG_NF_TABLES_BRIDGE to 'y', and related options to 'm'. 宋文武 2019-09-04gnu: linux-libre: Enable built-in ext4 support.•••When running qemu-img from (gnu system vm) with an aarch64 kernel, mounting ext4 partitions fails because no modprobe of ext4 module is made. Like for other kernel configs, provide built-in support for ext4 partitions. * gnu/packages/aux-files/linux-libre/5.2-arm64.conf: Enable built-in ext4, like in intel and armhf configs. Mathieu Othacehe 2019-09-04gnu: ungoogled-chromium: Allow microphone access.•••Fixes <https://bugs.gnu.org/36961>. * gnu/packages/aux-files/chromium/master-preferences.json: Remove "audio_capture_enabled" flag. Marius Bakke