aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-31 04:18:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:53:58 +0200
commit35db8f4ede48d000d62436663f19681cdc76691c (patch)
treeafcf43e5dec998c634de794f28e03824ead61195
parente2ad36d0747238382d3cdfe0e3b71e68d429f3cc (diff)
downloadguix-35db8f4ede48d000d62436663f19681cdc76691c.tar.gz
guix-35db8f4ede48d000d62436663f19681cdc76691c.zip
gnu: emacs-fill-column-indicator: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-fill-column-indicator)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 539ae7ee28..da837dbc35 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2229,13 +2229,13 @@ keep pressing the key until it selects what you want. There's also
(version "1.89")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/alpaker/Fill-Column-Indicator"
- "/archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alpaker/Fill-Column-Indicator.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "09ab01np14bdcsr38xf95kpnvxzqr46mdjmphg3pigwnx39a3jvg"))))
+ (base32 "010kf8jsly74y7m6mmkn1h6y205kz23zphs50zgy2nag2p88rz9y"))))
(build-system emacs-build-system)
(home-page "https://www.emacswiki.org/emacs/FillColumnIndicator")
(synopsis "Graphically indicate the fill column")