aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-26 11:24:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-03 16:59:41 +0100
commit353620e84a39ee445c97363b68da4ff1d16e6fe0 (patch)
treef9cd37e024e83cf4d10fc231199fd22f3628129d
parent2f5201970e295f12fb7ffc4bde18421996f4da1e (diff)
downloadguix-353620e84a39ee445c97363b68da4ff1d16e6fe0.tar.gz
guix-353620e84a39ee445c97363b68da4ff1d16e6fe0.zip
gnu: r-megadepth: Add missing inputs and disable tests.
* gnu/packages/bioconductor.scm (r-megadepth)[propagated-inputs]: Add megadepth. [arguments]: Disable tests. [inputs]: Remove empty field. [properties]: Tell updater to keep megadepth as a propagated input. Change-Id: Idbbc371c2d66aa7c0d7e2add13fa35a5b4f9cd77
-rw-r--r--gnu/packages/bioconductor.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 8557c3a650..6eeb809c59 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -24593,11 +24593,15 @@ to annotation.")
(sha256
(base32
"1cay30y7cc6lpikcp4ncx69zjg4kyn152z5b8fhw159n6cb1z19n"))))
- (properties `((upstream-name . "megadepth")))
+ (properties
+ `((upstream-name . "megadepth")
+ (updater-extra-propagated-inputs . ("megadepth"))))
(build-system r-build-system)
- (inputs (list))
+ ;; Tests attempt to install latest version of megadepth.
+ (arguments (list #:tests? #false))
(propagated-inputs
- (list r-cmdfun
+ (list megadepth
+ r-cmdfun
r-dplyr
r-fs
r-genomicranges