aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2019-11-07 10:22:02 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-08 22:30:40 +0100
commit34bcfae26eae67e13d29c3b08a90c43ccab0c054 (patch)
treee3a8f2f54b99fc41257d62ce9eb7a4df6ea12bcc
parent0f0bffc4bd054336b977f765897508716a3d1d60 (diff)
downloadguix-34bcfae26eae67e13d29c3b08a90c43ccab0c054.tar.gz
guix-34bcfae26eae67e13d29c3b08a90c43ccab0c054.zip
gnu: Add gnome-shell-extension-noannoyance.
* gnu/packages/gnome-xyz: (gnome-shell-extension-noannoyance): New variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/gnome-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 3131ed662a..8c45b552e8 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -95,3 +95,34 @@ overview, transforming it into a dock for easier application launching and
faster window switching.")
(home-page "https://micheleg.github.io/dash-to-dock/")
(license license:gpl2+)))
+
+(define-public gnome-shell-extension-noannoyance
+ (package
+ (name "gnome-shell-extension-noannoyance")
+ (version "5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BjoernDaase/noannoyance.git")
+ (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
+ (sha256
+ (base32
+ "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
+ (file-name (git-file-name name version))))
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((dst (string-append
+ (assoc-ref %outputs "out")
+ "/share/gnome-shell/extensions/"
+ "noannoyance@daase.net")))
+ (mkdir-p dst)
+ (copy-recursively (assoc-ref %build-inputs "source") dst)))))
+ (synopsis "Removes 'Window is ready' annotation")
+ (description "One of the many extensions, that remove this message.
+It uses ES6 syntax and claims to be more actively maintained than others.")
+ (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
+ (license license:gpl2)))
(user-group (name "b") (id %id-min)) (user-group (name "c"))) vlist-null)) (test-equal "allocate-groups with previous state" ;; Make sure bits of state are preserved: password, GID, no reuse of ;; previously-used GIDs. (list (group-entry (name "s") (gid (- %system-id-max 1))) (group-entry (name "t") (gid (- %system-id-max 2))) (group-entry (name "a") (gid 30000) (password #f) (members '("alice" "bob"))) (group-entry (name "b") (gid 30001) (password "bar") (members '("charlie")))) (allocate-groups (list (user-group (name "s") (system? #t)) (user-group (name "t") (system? #t)) (user-group (name "a") (password "foo")) (user-group (name "b"))) (alist->vhash `(("a" . "bob") ("a" . "alice") ("b" . "charlie"))) (list (group-entry (name "a") (gid 30000)) (group-entry (name "b") (gid 30001) (password "bar")) (group-entry (name "removed") (gid %system-id-max))))) (test-equal "allocate-groups with previous state, looping" ;; Check that allocation starts after the highest previously-used GID, and ;; loops back to the lowest GID. (list (group-entry (name "a") (gid (- %id-max 1))) (group-entry (name "b") (gid %id-min)) (group-entry (name "c") (gid (+ 1 %id-min)))) (allocate-groups (list (user-group (name "a")) (user-group (name "b")) (user-group (name "c"))) vlist-null (list (group-entry (name "d") (gid (- %id-max 2)))))) (test-equal "allocate-passwd" ;; Allocate UIDs in a stateless fashion. (list (password-entry (name "alice") (uid %id-min) (gid 1000) (real-name "Alice") (shell "/bin/sh") (directory "/home/alice")) (password-entry (name "bob") (uid (+ 1 %id-min)) (gid 1001) (real-name "Bob") (shell "/bin/gash") (directory "/home/bob")) (password-entry (name "sshd") (uid %system-id-max) (gid 500) (real-name "sshd") (shell "/nologin") (directory "/var/empty")) (password-entry (name "guix") (uid 30000) (gid 499) (real-name "Guix") (shell "/nologin") (directory "/var/empty"))) (allocate-passwd (list (user-account (name "alice") (comment "Alice") (shell "/bin/sh") (group "users")) (user-account (name "bob") (comment "Bob") (shell "/bin/gash") (group "wheel")) (user-account (name "sshd") (system? #t) (comment "sshd") (home-directory "/var/empty") (shell "/nologin") (group "sshd")) (user-account (name "guix") (system? #t) (comment "Guix") (home-directory "/var/empty") (shell "/nologin") (group "guix") (uid 30000))) (list (group-entry (name "users") (gid 1000)) (group-entry (name "wheel") (gid 1001)) (group-entry (name "sshd") (gid 500)) (group-entry (name "guix") (gid 499))))) (test-equal "allocate-passwd with previous state" ;; Make sure bits of state are preserved: UID, no reuse of previously-used ;; UIDs, and shell. (list (password-entry (name "alice") (uid 1234) (gid 1000) (real-name "Alice Smith") (shell "/bin/sh") (directory "/home/alice")) (password-entry (name "charlie") (uid 1236) (gid 1000) (real-name "Charlie") (shell "/bin/sh") (directory "/home/charlie"))) (allocate-passwd (list (user-account (name "alice") (comment "Alice") (shell "/bin/sh") ;honored (group "users")) (user-account (name "charlie") (comment "Charlie") (shell "/bin/sh") (group "users"))) (list (group-entry (name "users") (gid 1000))) (list (password-entry (name "alice") (uid 1234) (gid 9999) (real-name "Alice Smith") (shell "/gnu/.../bin/gash") ;ignored (directory "/home/alice")) (password-entry (name "bob") (uid 1235) (gid 1001) (real-name "Bob") (shell "/bin/sh") (directory "/home/bob"))))) (test-equal "user+group-databases" ;; The whole shebang. (list (list (group-entry (name "a") (gid %id-min) (members '("bob"))) (group-entry (name "b") (gid (+ 1 %id-min)) (members '("alice"))) (group-entry (name "s") (gid %system-id-max))) (list (password-entry (name "alice") (real-name "Alice") (uid %id-min) (gid %id-min) (directory "/a")) (password-entry (name "bob") (real-name "Bob") (uid (+ 1 %id-min)) (gid (+ 1 %id-min)) (directory "/b")) (password-entry (name "nobody") (uid 65534) (gid %system-id-max) (directory "/var/empty"))) (list (shadow-entry (name "alice") (last-change 100) (password (crypt "initial pass" "$6$"))) (shadow-entry (name "bob") (last-change 50) (password (crypt "foo" "$6$"))) (shadow-entry (name "nobody") (last-change 100)))) (call-with-values (lambda () (user+group-databases (list (user-account (name "alice") (comment "Alice") (home-directory "/a") (group "a") (supplementary-groups '("b")) (password (crypt "initial pass" "$6$"))) (user-account (name "bob") (comment "Bob") (home-directory "/b") (group "b") (supplementary-groups '("a"))) (user-account (name "nobody") (group "s") (uid 65534) (home-directory "/var/empty"))) (list (user-group (name "a")) (user-group (name "b")) (user-group (name "s") (system? #t))) #:current-passwd '() #:current-shadow (list (shadow-entry (name "bob") (password (crypt "foo" "$6$")) (last-change 50))) #:current-groups '() #:current-time (lambda (type) (make-time type 0 (* 24 3600 100))))) list)) (test-end "accounts")