aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-02-10 23:16:46 +0100
committerLudovic Courtès <ludo@gnu.org>2017-02-10 23:39:46 +0100
commit340f9b9fa0bdbe65c570b57504d39ff30fc1dd4a (patch)
treef5919487b8a26291c6fa7db6793a079be1d757db
parent533bc51469bf291ac935a463bcbd8fdb93b5976c (diff)
downloadguix-340f9b9fa0bdbe65c570b57504d39ff30fc1dd4a.tar.gz
guix-340f9b9fa0bdbe65c570b57504d39ff30fc1dd4a.zip
gnu: librstp: Allow tests to run.
Fixes <http://bugs.gnu.org/25669>. Reported by Maxim Cournoyer <maxim.cournoyer@gmail.com>. Before that, the sender process in test/rtpw_test.sh would try to read words from the parent directory, and thus it would return almost immediately (as if it had read an empty file, no error). * gnu/packages/telephony.scm (libsrtp)[inputs]: Add PSMISC. [arguments]: In 'patch-dictionary-location' phase, set the name of the 'FAQ' file rather than the name of its parent directory.
-rw-r--r--gnu/packages/telephony.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index c393caace8..b0cefe4056 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -215,7 +215,8 @@ internet.")
(base32
"1w2g623qkd7gdyydglx2hr4s2y237lg0nszjmy7z8d2iq8hvb9sn"))))
(native-inputs
- `(("procps" ,procps)))
+ `(("psmisc" ,psmisc) ;some tests require 'killall'
+ ("procps" ,procps)))
(build-system gnu-build-system)
(arguments
'(#:test-target "runtest"
@@ -234,8 +235,8 @@ internet.")
(substitute* "test/rtpw.c"
(("/usr/share/dict/words")
(string-append (assoc-ref %build-inputs "procps")
- "/share/doc/procps-ng"))
- (("words.txt") "FAQ"))
+ "/share/doc/procps-ng/FAQ"))
+ (("words.txt") "FAQ"))
#t)))))
(synopsis "Secure RTP (SRTP) Reference Implementation")
(description "This package provides an implementation of the Secure
wise. Ludovic Courtès 2018-10-19tests: Run 'guix pack' tests using the external store....Fixes <https://bugs.gnu.org/32184>. * guix/tests.scm (call-with-external-store): New procedure. (with-external-store): New macro. * tests/pack.scm (%store): Remove. (test-assertm): Add 'store' parameter. ("self-contained-tarball"): Wrap in 'with-external-store'. * tests/guix-pack.sh: Connect to the external store, if possible, by setting NIX_STORE_DIR and GUIX_DAEMON_SOCKET. Remove most uses of '--bootstrap'. Ludovic Courtès 2018-07-05tests: Skip 'guix-pack.sh'....This works around a regression introduced in commit 66e9944e078cbb9e0d618377dd6df6e639640efa while waiting for a proper fix. * tests/guix-pack.sh: Add "exit 77". Ludovic Courtès 2018-05-19tests: Skip 'tests/guix-pack.sh' when networking is missing....The test could fail because "static-binaries.tar.xz" is missing, for instance. * tests/guix-pack.sh: Require a network connection to be on the safe side. This reverts part of 47a60325ca650e8fc1a291c8655b4297f4de8deb. Ludovic Courtès 2018-05-10pack: Add '--relocatable'....* gnu/packages/aux-files/run-in-namespace.c: New file. * Makefile.am (AUX_FILES): Add it. * guix/scripts/pack.scm (<c-compiler>): New record type. (c-compiler, bootstrap-c-compiler, c-compiler-compiler): New procedures. (self-contained-tarball): Use 'relative-file-name' for the SOURCE -> TARGET symlink. (docker-image): Add 'defmod' to please Geiser. (wrapped-package, map-manifest-entries): New procedures. (%options, show-help): Add --relocatable. (guix-pack): Honor it. Ludovic Courtès 2018-05-07pack: Fix handling of '-e'....Fixes a regression introduced in aad16cc1965ab3488449c262455eb29b15c77e95. Reported by Julien Lepiller. * guix/scripts/pack.scm (guix-pack)[manifest-from-args]: In 'match-lambda', add clause for single packages. * tests/guix-pack.sh: Add test for '-e'. Ludovic Courtès 2018-05-07pack: Honor package transformation options....Previously they would silently be ignored. * guix/scripts/pack.scm (guix-pack)[manifest-from-args]: Add 'store' parameter. Call 'options->transformation' and use it. Move 'with-store' and 'parameterize' around the 'let'. * tests/guix-pack.sh: Add test using '--with-source'. Ludovic Courtès 2018-05-07pack: Adjust test to cope with GC'd profiles....Previous "test -x opt/gnu/bin/guile" would fail if the store item "opt/gnu/bin" points to had been GC'd. * tests/guix-pack.sh: Replace "test -x" with "test -L" to deal with store items that have been reclaimed. Ludovic Courtès 2018-03-24tests: Add tests for "guix pack"....* guix/scripts/pack.scm (bootstrap-xz): New variable. (%options) <--bootstrap>: New option. (show-help): Document the new --bootstrap option. (guix-pack): When --bootstrap is specified, use the bootstrap Guile, tar, and xz to build the pack, and do not use any profile hooks or locales. * doc/guix.texi (Invoking guix pull): Document the new --bootstrap option. * tests/guix-pack.sh: New file. * Makefile.am (SH_TESTS): Add guix-pack.sh. * gnu/packages/package-management.scm (guix) <inputs>: Add util-linux. Chris Marusich