aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-09-12 22:31:37 +0200
committerAndreas Enge <andreas@enge.fr>2023-09-16 09:45:06 +0200
commit33e64b4509d595eb324790c9a7e134de10d2f491 (patch)
treebb2f7af59b3975707a79726fa8a50ad1e47a8e9b
parent5b236fbcccc123d4ccda6063b36c8d6f6c1a57f6 (diff)
downloadguix-33e64b4509d595eb324790c9a7e134de10d2f491.tar.gz
guix-33e64b4509d595eb324790c9a7e134de10d2f491.zip
gnu: ocaml: Allow not to build the native compiler.
Build "defaultentry", not "world.opt", so that the build system decides whether to build the native compiler or just the bytecode compiler. The native compiler is not available for 32-bit architectures. * gnu/packages/ocaml.scm (ocaml-5.0)[arguments]: Change make-flags. Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/ocaml.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8ff755aea9..ea9d3e3594 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -219,7 +219,7 @@ This package produces a native @command{ocamlc} and a bytecode @command{ocamllex
(arguments
`(#:configure-flags '("--enable-ocamltest")
#:test-target "tests"
- #:make-flags '("world.opt")
+ #:make-flags '("defaultentry")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-/bin/sh-references