aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2025-02-12 14:33:21 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2025-02-24 23:07:01 +0100
commit33c76a75f84e9243f6b71fc0dda834e63ad3024a (patch)
tree87ea7ca21ab170a63d55d44ea718f67b11683eaf
parent5a6f60ab451a4271ed48cf5e0e2b07990c761deb (diff)
downloadguix-33c76a75f84e9243f6b71fc0dda834e63ad3024a.tar.gz
guix-33c76a75f84e9243f6b71fc0dda834e63ad3024a.zip
gnu: Add emacs-age.
* gnu/packages/emacs-xyz.scm (emacs-age): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 59c1927135..441113cafb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -116,7 +116,7 @@
;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
-;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022, 2024, 2025 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;; Copyright © 2023 Simon Streit <simon@netpanic.org>
@@ -437,6 +437,30 @@ states–that is, any major mode that supports the bookmark system is
compatible.")
(license license:gpl3+)))
+(define-public emacs-age
+ (package
+ (name "emacs-age")
+ (version "0.1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anticomputer/age.el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1703ijdgahanzkrs0w3j1l563969qnsw872vkdsmfj7qw1940ndj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/anticomputer/age.el")
+ (synopsis "Age Encryption support for Emacs")
+ (description
+ "This package provides transparent Age file encryption and decryption
+in Emacs. It is based on the Emacs EasyPG code and offers similar Emacs file
+handling for Age encrypted files: maintain @file{.org.age} encrypted Org
+files, provide Age encrypted authentication information out of
+@file{.authinfo.age}, open/edit/save Age encrypted files via Tramp...")
+ (license license:gpl3+)))
+
(define-public emacs-bookmark-plus
(package
(name "emacs-bookmark-plus")