aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-28 21:38:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:45:10 +0300
commit33851ce196e67ea26cd96c66ca800050aacdd50b (patch)
tree9e9886f9e925aa503c853706b41a896a5f0124ae
parentda4c49e45c5d8589b60080a1297a4ae2c99e37d1 (diff)
downloadguix-33851ce196e67ea26cd96c66ca800050aacdd50b.tar.gz
guix-33851ce196e67ea26cd96c66ca800050aacdd50b.zip
gnu: Add rust-lopdf-0.31.
* gnu/packages/crates-io.scm (rust-lopdf-0.31): New variable. (rust-lopdf-0.29): Inherit from rust-lopdf-0.31. Change-Id: I602756f969e47375f538a7334b2c105515f15126
-rw-r--r--gnu/packages/crates-io.scm50
1 files changed, 41 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3ab967ec3c..660dcc0945 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -38687,8 +38687,47 @@ explosion.")
image together with its neighboring pixels.")
(license license:expat)))
+(define-public rust-lopdf-0.31
+ (package
+ (name "rust-lopdf")
+ (version "0.31.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lopdf" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0npqs454hz7z8ycldyi154fxmra0vkmp5xbjbzm346sb32vf3j07"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-chrono" ,rust-chrono-0.4)
+ ("rust-encoding-rs" ,rust-encoding-rs-0.8)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-image" ,rust-image-0.24)
+ ("rust-itoa" ,rust-itoa-1)
+ ("rust-linked-hash-map" ,rust-linked-hash-map-0.5)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-md5" ,rust-md5-0.7)
+ ("rust-nom" ,rust-nom-7)
+ ("rust-pom" ,rust-pom-3)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-weezl" ,rust-weezl-0.1))
+ #:cargo-development-inputs (("rust-clap" ,rust-clap-4)
+ ("rust-env-logger" ,rust-env-logger-0.10)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-shellexpand" ,rust-shellexpand-3)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (home-page "https://github.com/J-F-Liu/lopdf")
+ (synopsis "Rust library for PDF document manipulation")
+ (description
+ "This package provides a Rust library for PDF document manipulation.")
+ (license license:expat)))
+
(define-public rust-lopdf-0.29
(package
+ (inherit rust-lopdf-0.31)
(name "rust-lopdf")
(version "0.29.0")
(source
@@ -38698,7 +38737,6 @@ image together with its neighboring pixels.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1p59fkn9rkas0jywm7z24970k3lpv71sxxabmkmnig3d1p26j3yy"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-chrono" ,rust-chrono-0.4)
@@ -38713,14 +38751,8 @@ image together with its neighboring pixels.")
("rust-rayon" ,rust-rayon-1)
("rust-time" ,rust-time-0.2)
("rust-weezl" ,rust-weezl-0.1))
- #:cargo-development-inputs
- (("rust-env-logger" ,rust-env-logger-0.9)
- ("rust-tempfile" ,rust-tempfile-3))))
- (home-page "https://github.com/J-F-Liu/lopdf")
- (synopsis "Rust library for PDF document manipulation")
- (description
- "This package provides a Rust library for PDF document manipulation.")
- (license license:expat)))
+ #:cargo-development-inputs (("rust-env-logger" ,rust-env-logger-0.9)
+ ("rust-tempfile" ,rust-tempfile-3))))))
(define-public rust-lopdf-0.26
(package