aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-04 23:14:58 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-04 23:57:36 +0800
commit33665c52c4670bc3b4d337c89ac9cc6c4c69b26f (patch)
tree30106884d5ed0a7ee3541ba868c3f0c30c580d13
parent85d00a60b53c4992d0e131dc50e6494de4ebfee6 (diff)
downloadguix-33665c52c4670bc3b4d337c89ac9cc6c4c69b26f.tar.gz
guix-33665c52c4670bc3b4d337c89ac9cc6c4c69b26f.zip
gnu: frrouting: Update to 10.1.1.
* gnu/packages/networking.scm (frrouting): Update to 10.1.1. [source]: Switch to git-fetch. [inputs]: Add libelf and protobuf-c. [native-inputs]: Add autoconf, automake, libtool, flex, and bison. [arguments]<#:configure-flags>: Add --sysconfdir=/etc. Change-Id: I54d589a314c20f19a1c0096e77dc75d9dd1b5c47
-rw-r--r--gnu/packages/networking.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index be8c63899b..dc5d58791b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -121,6 +121,7 @@
#:use-module (gnu packages dns)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages elf)
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gawk)
@@ -4092,20 +4093,25 @@ for interacting with an OpenDHT distributed network.")
(define-public frrouting
(package
(name "frrouting")
- (version "7.5.1")
+ (version "10.1.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/FRRouting/frr/releases/"
- "download/frr-" version "/frr-" version
- ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FRRouting/frr")
+ (commit (string-append "frr-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1r7gh5h27ii7d1d0z0x48wx7hs8vvympv3gqvy3cwzg05q5vk9xs"))))
+ "06gn2wgnd97fgzf7yd9v5fv8fanjw02cy0rx7kgq7x7gnzbg1yhn"))))
(build-system gnu-build-system)
(inputs
- (list c-ares json-c libcap libxcrypt libyang readline))
+ (list c-ares json-c libcap libxcrypt libyang libelf protobuf-c readline))
(native-inputs
- (list perl pkg-config python-wrapper python-pytest))
+ (list autoconf automake
+ libtool perl pkg-config python-wrapper python-pytest
+ flex
+ bison))
+ (arguments (list #:configure-flags #~(list "--sysconfdir=/etc")))
(home-page "https://frrouting.org/")
(synopsis "IP routing protocol suite")
(description "FRRouting (FRR) is an IP routing protocol suite which includes