aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 21:54:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:39 +0200
commit32c17d6ab3d807528b9a71c402d58518265def04 (patch)
tree3b473482a7665c924ec6e85f9170298570bc3dce
parentff4e6c2309b25515af74cb1467ee4abe3095420e (diff)
downloadguix-32c17d6ab3d807528b9a71c402d58518265def04.tar.gz
guix-32c17d6ab3d807528b9a71c402d58518265def04.zip
gnu: texlive-wrapfig: Refresh package definition.
* gnu/packages/tex.scm (texlive-wrapfig): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 390ca5c686..47cd09a07d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8597,13 +8597,16 @@ implements an easy to use interface for these symbols.")
(define-public texlive-wrapfig
(package
- (inherit
- (simple-texlive-package
- "texlive-wrapfig"
- (list "doc/latex/wrapfig/" "tex/latex/wrapfig/")
- (base32 "0wk1vp0dqsp597xzsqbwj8xk80v7d77qmpjir84n54f920rf9ka9")
- #:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/wrapfig")
+ (name "texlive-wrapfig")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/wrapfig/" "tex/latex/wrapfig/")
+ (base32
+ "0wk1vp0dqsp597xzsqbwj8xk80v7d77qmpjir84n54f920rf9ka9")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/wrapfig")
(synopsis "Produces figures which text can flow around")
(description
"This package allows figures or tables to have text wrapped around them.