aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:40 +0200
commit32b463508aedf4d882c577d684b36024ae82223a (patch)
treec4b3a020d2596b023b34af08ce9fc28ccab4e9d9
parentee9958d6ded90409a034e486ab38955a02a57459 (diff)
downloadguix-32b463508aedf4d882c577d684b36024ae82223a.tar.gz
guix-32b463508aedf4d882c577d684b36024ae82223a.zip
gnu: Add texlive-rgltxdoc.
* gnu/packages/tex.scm (texlive-rgltxdoc): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 26c8f787a7..e1f0f72e0c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94027,6 +94027,28 @@ semi-automatic grid typesetting. It does more or less what the existing
do some horizontal movements to get to @samp{Tab} positions.")
(license license:lppl1.3c)))
+(define-public texlive-rgltxdoc
+ (package
+ (name "texlive-rgltxdoc")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/rgltxdoc/"
+ "source/latex/rgltxdoc/"
+ "tex/latex/rgltxdoc/")
+ (base32
+ "0wbgxl24d67hcwy01vsajg2am6ia6dagxgl32ql4854gcim0ypbj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/rgltxdoc")
+ (synopsis "Common code for documentation of the author's packages")
+ (description
+ "This package combines several other packages and defines additional macros
+and environments for documenting LaTeX code. The package mainly serves the
+purpose of combining the preferences used in the author's own package
+documentations.")
+ (license license:lppl1.2+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar