aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:44:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:22 +0200
commit32ab7ef34a5207b5813289311e03e8aa3dba0a7c (patch)
treeb4f46e49dc512d0286a7ada8768f159580f0c38a
parentda14c67d79cfd29573d2949d68f4b54c839586f1 (diff)
downloadguix-32ab7ef34a5207b5813289311e03e8aa3dba0a7c.tar.gz
guix-32ab7ef34a5207b5813289311e03e8aa3dba0a7c.zip
gnu: Add texlive-catcodes.
* gnu/packages/tex.scm (texlive-catcodes): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 85637199f2..9fbf6fef3f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1365,6 +1365,34 @@ south-east, etc.); 12 types and 32 directions are available.")
in Python, C and Pascal. Program source files may also be input.")
(license license:public-domain)))
+(define-public texlive-catcodes
+ (package
+ (name "texlive-catcodes")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/catcodes/"
+ "source/generic/catcodes/"
+ "tex/generic/catcodes/")
+ (base32
+ "0di6rd5c0viiwvc6ncwndah38q318l3s1pf47ddmzjdq6rys9s33")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/catcodes")
+ (synopsis "Generic handling of TeX category codes")
+ (description
+ "The bundle deals with category code switching; the packages of the
+bundle should work with any TeX format (with the support of the
+@code{plainpkg} package). The bundle provides:
+@itemize
+@item @file{stacklet.sty}, which supports stacks that control the use of
+different catcodes;
+@item @file{actcodes.sty}, which deals with active characters;
+@item @file{catchdq.sty}, which provides a simple quotation character control
+mechanism.
+@end itemize")
+ (license license:lppl1.3+)))
+
(define-public texlive-dosepsbin
(package
(name "texlive-dosepsbin")