aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2025-03-05 21:29:10 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2025-03-05 22:44:16 +0900
commit328c8e5dd28c67dd9b3c787527c16280290a6b71 (patch)
treea706b7677d63d0712a333821e5e2339ad9699ff4
parent20e352a12e43de0d094f916797e42308aad469af (diff)
downloadguix-328c8e5dd28c67dd9b3c787527c16280290a6b71.tar.gz
guix-328c8e5dd28c67dd9b3c787527c16280290a6b71.zip
gnu: keepassxc: Update to 2.7.10.
* gnu/packages/password-utils.scm (keepassxc): Update to 2.7.10. [arguments]: Extend the record-clipboard-programs phase. Skip an extra test in the check phase override, and document why. Change-Id: I832b6a355ed76285953b70373d6731689717af61
-rw-r--r--gnu/packages/password-utils.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index c4a2cf95f0..bce4af8e5f 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -229,7 +229,7 @@ human.")
(define-public keepassxc
(package
(name "keepassxc")
- (version "2.7.9")
+ (version "2.7.10")
(source
(origin
(method url-fetch)
@@ -237,7 +237,7 @@ human.")
"/releases/download/" version "/keepassxc-"
version "-src.tar.xz"))
(sha256
- (base32 "1za6xnwnq68gswz8vh7s5wia1bdhnia11hcb7p3dl3f049gy8i1w"))))
+ (base32 "1ylxh72bpf4pzsj13j8zlxpidp6aygaikw454n228v4q81j6vrsw"))))
(build-system qt-build-system)
(arguments
(list
@@ -269,14 +269,20 @@ human.")
(string-append
"QString::fromUtf8(\""
(search-input-file inputs "bin/wl-copy")
- "\")")))))
+ "\")")))
+ (substitute* "src/gui/Clipboard.cpp"
+ (("\"wl-copy\"")
+ (format #f "~s" (search-input-file inputs "bin/wl-copy"))))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- ;; "TestCli::testClip() Compared values are not the same".
- ;; Actual (((clipboard->text()))): ""
- ;; Expected (QString("Password")) : "Password"
- (invoke "ctest" "--exclude-regex" "testcli")))))))
+ ;; Entries have recently become sorted per the locale, and
+ ;; causes testentrymodel to fail when using the C locale (see:
+ ;; https://github.com/keepassxreboot/keepassxc/issues/11813).
+ ;; testClip runs 'xclip', which hangs in the container,
+ ;; perhaps because it lacks a TTY.
+ (invoke "ctest" "--exclude-regex"
+ "testentrymodel|testcli")))))))
(native-inputs
(append
(list qttools-5)