aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2025-02-20 14:53:22 +0800
committer宋文武 <iyzsong@member.fsf.org>2025-02-26 16:17:30 +0800
commit31f261dedaf0c554f704942c009a763a9d021e25 (patch)
treeb9472411cf8979886b50a12927393c53ea562099
parentec345d42f58d3e8d75ca6ee01ae5364a7a32a792 (diff)
downloadguix-31f261dedaf0c554f704942c009a763a9d021e25.tar.gz
guix-31f261dedaf0c554f704942c009a763a9d021e25.zip
gnu: Add xmahjongg.
* gnu/packages/games.scm (xmahjongg): New variable. Change-Id: I88440563216e5927152bebd381dd3efa065fc251 Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/games.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index eaf3fcd908..546c513de0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12500,6 +12500,26 @@ on the pitch of the voice and the rhythm of singing.")
(home-page "https://usdx.eu/")
(license license:gpl2+)))
+(define-public xmahjongg
+ (package
+ (name "xmahjongg")
+ (version "3.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.lcdf.org/xmahjongg/xmahjongg-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1kzz8y34q7wibcrmfb3p9rrz88qriz4slxpf1yrrfny23il66g94"))))
+ (build-system gnu-build-system)
+ (inputs (list libx11))
+ (home-page "http://www.lcdf.org/xmahjongg/")
+ (synopsis "Solitaire Mah Jongg game")
+ (description
+ "Xmahjongg is a simple solitaire game. The object is to remove all Mah
+Jongg tiles from the playing field by taking one matching pair at a time.")
+ (license license:gpl2+)))
+
(define-public steam-devices-udev-rules
;; Last release from 2019-04-10
(let ((commit "13443480a64fe8f10676606bd57da6de89f8ccb1")