aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2024-11-03 13:04:06 +0100
committerJelle Licht <jlicht@fsfe.org>2024-12-18 22:02:20 +0100
commit31abde9afaeeabec8d267059c3e15d17081f0de8 (patch)
treef1b1df464df774d9cdf421120ce22e77dadae533
parentd4caaf2a92d7b52a0961c15b7e01ffd807460a90 (diff)
downloadguix-31abde9afaeeabec8d267059c3e15d17081f0de8.tar.gz
guix-31abde9afaeeabec8d267059c3e15d17081f0de8.zip
gnu: esbuild-node: Use node-lts instead of node.
* gnu/packages/web.scm (esbuild-node)[#:phases]<build-platform>: Remove workaround needed for building with older versions of Node. [native-inputs]: Replace node by node-lts. Change-Id: Iedf30dc1a395e674007c08ce6c0881dbb0f94f0e
-rw-r--r--gnu/packages/web.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8a214dfa36..3de10a0da7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2128,12 +2128,6 @@ directions.")
(add-after 'build 'build-platform
(lambda* (#:key unpack-path #:allow-other-keys)
(with-directory-excursion (string-append "src/" unpack-path)
- ;; We're using Node 10, which doesn't have this method.
- (substitute* "scripts/esbuild.js"
- (("exports.buildNativeLib" m)
- (string-append
- "Object.fromEntries = entries => entries.reduce((result, entry) => (result[entry[0]] = entry[1], result), {});\n"
- m)))
;; Must be writable.
(for-each make-file-writable (find-files "." "."))
(invoke "node" "scripts/esbuild.js"
@@ -2156,7 +2150,7 @@ directions.")
(invoke "make" "test-go"))))))))
(native-inputs
(modify-inputs (package-native-inputs esbuild)
- (append node)))))
+ (append node-lts)))))
(define-public wwwoffle
(package
@@ -9584,7 +9578,7 @@ the Fediring.")
(build-system python-build-system)
(propagated-inputs
(list curl
- node))
+ node-lts))
(inputs
(list python
youtube-dl